aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-weather/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-weather/APKBUILD')
-rw-r--r--community/gnome-weather/APKBUILD35
1 files changed, 27 insertions, 8 deletions
diff --git a/community/gnome-weather/APKBUILD b/community/gnome-weather/APKBUILD
index 0bdce455578..e9ac830f5c5 100644
--- a/community/gnome-weather/APKBUILD
+++ b/community/gnome-weather/APKBUILD
@@ -1,29 +1,48 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-weather
-pkgver=40.0
+pkgver=46.0
pkgrel=0
pkgdesc="GNOME Weather application"
url="https://wiki.gnome.org/Apps/Weather"
-arch="noarch !s390x !mips !mips64" # missing gjs
+# armhf and s390x and riscv64 blocked by gjs
+arch="noarch !armhf !s390x !riscv64"
license="GPL-2.0-only"
-makedepends="meson glib-dev gobject-introspection-dev gtk+3.0-dev gjs-dev
- geoclue-dev libgweather-dev libhandy1-dev"
+depends="
+ geoclue
+ gjs
+ gobject-introspection
+ gtk4.0
+ libadwaita
+ libgweather4
+ "
+makedepends="
+ geoclue-dev
+ gjs-dev
+ glib-dev
+ gobject-introspection-dev
+ gtk4.0-dev
+ libadwaita-dev
+ libgweather4-dev
+ meson
+ "
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang"
source="https://download.gnome.org/sources/gnome-weather/${pkgver%.*}/gnome-weather-$pkgver.tar.xz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="c4560c1a1535a0c2889c8cd934926217a7caceb1b646fa4bb961c7cbde38b9b545a567f24fb81e47c61a2ac3e456a5432e8979591eb5a169fe5849bbd99d6333 gnome-weather-40.0.tar.xz"
+sha512sums="
+b180b231359e7b1cfa593b9a536d77520d6183aa752a8900bb27a290bc5f6f9676da132897e51e2810baca57196c9328a8cbbbb172068f52409076e39ba87a8b gnome-weather-46.0.tar.xz
+"