aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-weather/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-weather/APKBUILD')
-rw-r--r--community/gnome-weather/APKBUILD34
1 files changed, 25 insertions, 9 deletions
diff --git a/community/gnome-weather/APKBUILD b/community/gnome-weather/APKBUILD
index c3b29faf6b8..e9ac830f5c5 100644
--- a/community/gnome-weather/APKBUILD
+++ b/community/gnome-weather/APKBUILD
@@ -1,26 +1,42 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-weather
-pkgver=41.0
+pkgver=46.0
pkgrel=0
pkgdesc="GNOME Weather application"
url="https://wiki.gnome.org/Apps/Weather"
-# s390x, mips64 and riscv64 blocked by gjs
-arch="noarch !s390x !mips64 !riscv64"
+# armhf and s390x and riscv64 blocked by gjs
+arch="noarch !armhf !s390x !riscv64"
license="GPL-2.0-only"
-makedepends="meson glib-dev gobject-introspection-dev gtk+3.0-dev gjs-dev
- geoclue-dev libgweather-dev libhandy1-dev"
+depends="
+ geoclue
+ gjs
+ gobject-introspection
+ gtk4.0
+ libadwaita
+ libgweather4
+ "
+makedepends="
+ geoclue-dev
+ gjs-dev
+ glib-dev
+ gobject-introspection-dev
+ gtk4.0-dev
+ libadwaita-dev
+ libgweather4-dev
+ meson
+ "
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang"
source="https://download.gnome.org/sources/gnome-weather/${pkgver%.*}/gnome-weather-$pkgver.tar.xz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -28,5 +44,5 @@ package() {
}
sha512sums="
-f625a83ecfffe1ad58aa268b6ab3009504f839f3d56e52c642bc23ee32c0b51638888de17a1b4bc0990b2fd6718a7266fe5cd79230594a06ae58a816308b2b99 gnome-weather-41.0.tar.xz
+b180b231359e7b1cfa593b9a536d77520d6183aa752a8900bb27a290bc5f6f9676da132897e51e2810baca57196c9328a8cbbbb172068f52409076e39ba87a8b gnome-weather-46.0.tar.xz
"