aboutsummaryrefslogtreecommitdiffstats
path: root/community/gns3-server/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gns3-server/APKBUILD')
-rw-r--r--community/gns3-server/APKBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/community/gns3-server/APKBUILD b/community/gns3-server/APKBUILD
deleted file mode 100644
index 1d5f9da5f8f..00000000000
--- a/community/gns3-server/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=gns3-server
-pkgver=2.2.8
-pkgrel=0
-pkgdesc="GNS3 network simulator. Server package."
-url="https://github.com/GNS3/gns3-server"
-arch="all !mips !mips64" # blocked by py3-py-cpuinfo
-license="GPL-3.0-or-later"
-depends="busybox dynamips python3
- py3-aiohttp-gns3 py3-aiohttp-cors-gns3
- py3-async-timeout-gns3 py3-jsonschema-gns3
- py3-pytest py3-raven
- py3-psutil-gns3 py3-jinja2
- py3-async_generator py3-aiofiles-gns3
- py3-distro py3-py-cpuinfo
- "
-makedepends="busybox-static py3-setuptools python3-dev linux-headers"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/gns3-server/archive/v$pkgver.tar.gz
- requirements.patch"
-
-build() {
- # Upstream includes busybox binary for x86_64. We want to replace it by
- # $CARCH binary
- if [ "$CARCH" != "x86_64" ] ; then
- busybox_bin=$(find . -name busybox -type f)
- cp /bin/busybox.static $busybox_bin
- fi
- python3 setup.py build
-}
-
-check() {
- python3 setup.py check
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname
- cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
-gns3-server has several optional packages that must be installed manually for additional functionality:
-
- apk add qemu
- apk add wiresark
- apk add ubridge
- apk add cpulimit
- apk add iouyap
- apk add vpcs
-EOF
-}
-
-sha512sums="3394d368c986ce8378739bdbc15359c46bdf787a38e18bae9035653dd6dc6683973bf1b7952137189f57fd83074f3d5ea6040f5d7a1d0503f6cf21d2835cd693 gns3-server-2.2.8.tar.gz
-a5bf609c2d3dd63d4d3c3ad7b57248d044b7764f277eaf3218b38002defea20dd6e66d48b11d249149edafe076ef5b3e1981e8fc6e8e9f819e414caa83584bce requirements.patch"