aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnuchess/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnuchess/APKBUILD')
-rw-r--r--community/gnuchess/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/community/gnuchess/APKBUILD b/community/gnuchess/APKBUILD
index 9fd4ce5f88f..a0a33c21b33 100644
--- a/community/gnuchess/APKBUILD
+++ b/community/gnuchess/APKBUILD
@@ -1,22 +1,27 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnuchess
-pkgver=6.2.6
-pkgrel=0
+pkgver=6.2.9
+pkgrel=1
pkgdesc="The GNU chess program"
url="https://www.gnu.org/software/chess/"
arch="all"
-makedepends="automake autoconf gettext-dev"
+makedepends="automake autoconf gettext-dev xz"
license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
source="https://ftp.gnu.org/gnu/chess/gnuchess-$pkgver.tar.gz"
+# secfixes:
+# 6.2.9-r0:
+# - CVE-2021-30184
+
prepare() {
default_prepare
autoreconf -fi
}
build() {
+ LDFLAGS="$LDFLAGS -Wl,-z,stack-size=2097152"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,4 +37,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="32bb36c54b73659752657ee43c7f9723e74ae974980e016c56d564c7870d1bc98ee40e407e0687df968fc2d4dc778a972282e3aea1ddca31dee1cce7e96da7e2 gnuchess-6.2.6.tar.gz"
+sha512sums="
+7e2ec9e14ab331ffaab2dd60da81b64b5c5a07cf14f9139d67c77886038512d15511939b8e683675ea6611e24ff2c38212a7f288540448c9225c263435f71963 gnuchess-6.2.9.tar.gz
+"