aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnunet-gtk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnunet-gtk/APKBUILD')
-rw-r--r--community/gnunet-gtk/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/gnunet-gtk/APKBUILD b/community/gnunet-gtk/APKBUILD
new file mode 100644
index 00000000000..2c28e7d9d52
--- /dev/null
+++ b/community/gnunet-gtk/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: xrs <xrs@mail36.net>
+# Maintainer: xrs <xrs@mail36.net>
+pkgname=gnunet-gtk
+pkgver=0.21.0
+pkgrel=0
+pkgdesc="Graphical user interface for GNUnet"
+url="https://gnunet.org"
+# s390x, riscv64, and ppc64le blocked by luatek -> texlive -> gnunet
+arch="all !s390x !ppc64le !riscv64"
+license="GPL-3.0-only"
+makedepends="gnunet-dev gtk+3.0-dev glade-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://ftpmirror.gnu.org/gnu/gnunet/gnunet-gtk-$pkgver.tar.gz"
+options="!check" # The GNUnet project lacks a good CI at the moment.
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-fs-app \
+ --disable-conversation-app
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+64b4ba030f08611d02b27935cfefc9f7339da8bae3dd5068c48dede2426ba0027a755f276389c3b9011c947480de4592ac283f913f092dc2cdf075bd962fd5ae gnunet-gtk-0.21.0.tar.gz
+"