aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-bindata-assetfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-bindata-assetfs/APKBUILD')
-rw-r--r--community/go-bindata-assetfs/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/community/go-bindata-assetfs/APKBUILD b/community/go-bindata-assetfs/APKBUILD
index 422e981a5e7..cb49bbb8008 100644
--- a/community/go-bindata-assetfs/APKBUILD
+++ b/community/go-bindata-assetfs/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Matthias Neugebauer <mtneug@mailbox.org>
# Contributor: omni <omni+alpine@hack.org>
-# Maintainer: Matthias Neugebauer <mtneug@mailbox.org>
+# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=go-bindata-assetfs
pkgver=1.0.1
-pkgrel=3
+pkgrel=24
pkgdesc="small utility which generates Go code to serve any file with net/http"
url="https://github.com/elazarl/go-bindata-assetfs"
arch="all"
@@ -13,19 +14,19 @@ makedepends="go"
options="!check" # no test suite
source="$pkgname-$pkgver.tar.gz::https://github.com/elazarl/go-bindata-assetfs/archive/v$pkgver.tar.gz"
+export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
- export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
- case $CARCH in
- mips*)
- export GOFLAGS="${GOFLAGS/-buildmode=pie}" # Not supported on mips(64)
- ;;
- esac
- export GOPATH="$srcdir"
- go build -ldflags="-s -w" -v -o bin/"$pkgname" ./"$pkgname"/main.go
+ go build -v -o bin/"$pkgname" ./"$pkgname"/main.go
}
package() {
install -Dm0755 bin/"$pkgname" -t "$pkgdir"/usr/bin
}
-sha512sums="fde5cd06393c82a8a1f9da5cc3054c1cc389328b5a232c5595a32755b2d613a83dc7777070152ad31ccbbbfbcf2419ad44bef89f88ceef4c6b7e5df8715309cf go-bindata-assetfs-1.0.1.tar.gz"
+sha512sums="
+fde5cd06393c82a8a1f9da5cc3054c1cc389328b5a232c5595a32755b2d613a83dc7777070152ad31ccbbbfbcf2419ad44bef89f88ceef4c6b7e5df8715309cf go-bindata-assetfs-1.0.1.tar.gz
+"