aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-bindata-assetfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-bindata-assetfs/APKBUILD')
-rw-r--r--community/go-bindata-assetfs/APKBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/community/go-bindata-assetfs/APKBUILD b/community/go-bindata-assetfs/APKBUILD
index 01f9aa61b17..aa43e767008 100644
--- a/community/go-bindata-assetfs/APKBUILD
+++ b/community/go-bindata-assetfs/APKBUILD
@@ -1,33 +1,32 @@
# Contributor: Matthias Neugebauer <mtneug@mailbox.org>
-# Maintainer: Matthias Neugebauer <mtneug@mailbox.org>
+# Contributor: omni <omni+alpine@hack.org>
+# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=go-bindata-assetfs
-pkgver=1.0.0
-pkgrel=2
-pkgdesc="A small utility which generates Go code to serve any file with net/http"
+pkgver=1.0.1
+pkgrel=25
+pkgdesc="small utility which generates Go code to serve any file with net/http"
url="https://github.com/elazarl/go-bindata-assetfs"
arch="all"
license="BSD-2-Clause"
depends="go-bindata"
makedepends="go"
options="!check" # no test suite
-source="$pkgname-$pkgver.tar.gz::https://github.com/elazarl/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/elazarl/$pkgname"
+source="$pkgname-$pkgver.tar.gz::https://github.com/elazarl/go-bindata-assetfs/archive/v$pkgver.tar.gz"
-prepare() {
- default_prepare
- mkdir -p "$srcdir/src/github.com/elazarl"
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
-}
+export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- cd "$builddir"
-
- GOPATH="$srcdir" CGO_ENABLED=0 go build -v -o bin/$pkgname ./go-bindata-assetfs
+ go build -v -o bin/"$pkgname" ./"$pkgname"/main.go
}
package() {
- install -Dm 755 "$builddir/bin/$pkgname" \
- "$pkgdir/usr/bin/$pkgname"
+ install -Dm0755 bin/"$pkgname" -t "$pkgdir"/usr/bin
}
-sha512sums="009111511b10b14e83b166eaf37c36e6fc96097770cd6b1865d034f4e90cc3232930b6f5591ee1a960af46d76a7456a96dcc2ccc112234cb0d382a9f9cc575c2 go-bindata-assetfs-1.0.0.tar.gz"
+sha512sums="
+fde5cd06393c82a8a1f9da5cc3054c1cc389328b5a232c5595a32755b2d613a83dc7777070152ad31ccbbbfbcf2419ad44bef89f88ceef4c6b7e5df8715309cf go-bindata-assetfs-1.0.1.tar.gz
+"