aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-bindata-assetfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-bindata-assetfs/APKBUILD')
-rw-r--r--community/go-bindata-assetfs/APKBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/community/go-bindata-assetfs/APKBUILD b/community/go-bindata-assetfs/APKBUILD
index 625d2ef8293..aa43e767008 100644
--- a/community/go-bindata-assetfs/APKBUILD
+++ b/community/go-bindata-assetfs/APKBUILD
@@ -1,31 +1,32 @@
# Contributor: Matthias Neugebauer <mtneug@mailbox.org>
-# Maintainer: Matthias Neugebauer <mtneug@mailbox.org>
+# Contributor: omni <omni+alpine@hack.org>
+# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=go-bindata-assetfs
pkgver=1.0.1
-pkgrel=0
-pkgdesc="A small utility which generates Go code to serve any file with net/http"
+pkgrel=25
+pkgdesc="small utility which generates Go code to serve any file with net/http"
url="https://github.com/elazarl/go-bindata-assetfs"
-arch="all !mips !mips64" # blocked by go
+arch="all"
license="BSD-2-Clause"
depends="go-bindata"
makedepends="go"
options="!check" # no test suite
source="$pkgname-$pkgver.tar.gz::https://github.com/elazarl/go-bindata-assetfs/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/elazarl/$pkgname"
-prepare() {
- default_prepare
- mkdir -p "$srcdir/src/github.com/elazarl"
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
-}
+export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- GOPATH="$srcdir" CGO_ENABLED=0 go build -v -o bin/$pkgname ./go-bindata-assetfs
+ go build -v -o bin/"$pkgname" ./"$pkgname"/main.go
}
package() {
- install -Dm 755 "$builddir/bin/$pkgname" \
- "$pkgdir/usr/bin/$pkgname"
+ install -Dm0755 bin/"$pkgname" -t "$pkgdir"/usr/bin
}
-sha512sums="fde5cd06393c82a8a1f9da5cc3054c1cc389328b5a232c5595a32755b2d613a83dc7777070152ad31ccbbbfbcf2419ad44bef89f88ceef4c6b7e5df8715309cf go-bindata-assetfs-1.0.1.tar.gz"
+sha512sums="
+fde5cd06393c82a8a1f9da5cc3054c1cc389328b5a232c5595a32755b2d613a83dc7777070152ad31ccbbbfbcf2419ad44bef89f88ceef4c6b7e5df8715309cf go-bindata-assetfs-1.0.1.tar.gz
+"