aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-bindata/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-bindata/APKBUILD')
-rw-r--r--community/go-bindata/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/go-bindata/APKBUILD b/community/go-bindata/APKBUILD
index 170e0ef752a..647f59339bd 100644
--- a/community/go-bindata/APKBUILD
+++ b/community/go-bindata/APKBUILD
@@ -2,23 +2,28 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=go-bindata
pkgver=3.1.3
-pkgrel=6
+pkgrel=26
pkgdesc="A small utility which generates Go code from any file"
url="https://github.com/go-bindata/go-bindata"
arch="all"
license="CC0-1.0"
makedepends="go"
options="!check" # No test suite
-source="go-bindata-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="go-bindata-$pkgver.tar.gz::https://github.com/go-bindata/go-bindata/archive/v$pkgver.tar.gz"
+
+export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- export GOPATH="$srcdir/go"
- export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
- go build -ldflags="-s -w" -v -o bin/"$pkgname" ./"$pkgname"
+ go build -v -o bin/"$pkgname" ./"$pkgname"
}
package() {
install -Dm0755 bin/"$pkgname" -t "$pkgdir"/usr/bin
}
-sha512sums="870f939cfb07b43c54000d39fa37e8151ca5c20d13eac9bde59e7ec3e2693d8386a1ea4b5372171dac42f8a4f69a754445cb9a4fa51a7a7ba9ec54f3e8a2a2f6 go-bindata-3.1.3.tar.gz"
+sha512sums="
+870f939cfb07b43c54000d39fa37e8151ca5c20d13eac9bde59e7ec3e2693d8386a1ea4b5372171dac42f8a4f69a754445cb9a4fa51a7a7ba9ec54f3e8a2a2f6 go-bindata-3.1.3.tar.gz
+"