aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-md2man/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-md2man/APKBUILD')
-rw-r--r--community/go-md2man/APKBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/community/go-md2man/APKBUILD b/community/go-md2man/APKBUILD
index 7d92397ab75..0cc09cd386e 100644
--- a/community/go-md2man/APKBUILD
+++ b/community/go-md2man/APKBUILD
@@ -1,36 +1,38 @@
-# Contributor: Jake Buchholz <tomalok@gmail.com>
-# Maintainer: Jake Buchholz <tomalok@gmail.com>
-
+# Contributor: Jake Buchholz Göktürk <tomalok@gmail.com>
+# Maintainer: Jake Buchholz Göktürk <tomalok@gmail.com>
pkgname=go-md2man
-pkgver=1.0.10
+pkgver=2.0.4
pkgrel=1
pkgdesc="Utility to convert markdown to man pages"
+options="net"
url="https://github.com/cpuguy83/go-md2man"
arch="all"
license="MIT"
makedepends="go"
subpackages="$pkgname-doc"
-source="go-md2man-$pkgver.tar.gz::https://github.com/cpuguy83/go-md2man/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/cpuguy83/go-md2man"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cpuguy83/go-md2man/archive/v$pkgver.tar.gz"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+export GOFLAGS="$GOFLAGS -modcacherw"
build() {
- cd "$srcdir"
- export GOPATH="$PWD"
- mkdir -p $(dirname "$builddir")
- ln -s "$PWD/go-md2man-$pkgver" "$builddir"
- cd $builddir
- CGO_ENABLED=0 go build
+ go build
+
+ ./go-md2man -in go-md2man.1.md -out go-md2man.1
}
check() {
- cd "$builddir"
- ./go-md2man -in go-md2man.1.md -out go-md2man.1
+ grep -q "User Manual" go-md2man.1
}
package() {
- cd "$builddir"
install -Dsm755 go-md2man "$pkgdir"/usr/bin/go-md2man
install -Dm644 go-md2man.1 "$pkgdir"/usr/share/man/man1/go-md2man.1
}
-sha512sums="cf9eb65bec7fc4293c4a867eca215a0ccb0c495c3e4e0759c04899887033c1edc2b4174d6975be73e56d621d5003b9b88f590f48276099c39458609b533eb40d go-md2man-1.0.10.tar.gz"
+sha512sums="
+2169f16a7ea769357511a72dff5f8a5728ec810ed4165e6a4b8c61ee2fa7bccab132bad94584a547c5ce4c63ca533a144a6c379d81f1977854eb22bfbe21e065 go-md2man-2.0.4.tar.gz
+"