aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-md2man/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-md2man/APKBUILD')
-rw-r--r--community/go-md2man/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/go-md2man/APKBUILD b/community/go-md2man/APKBUILD
index fb4d81c4173..0cc09cd386e 100644
--- a/community/go-md2man/APKBUILD
+++ b/community/go-md2man/APKBUILD
@@ -1,29 +1,31 @@
-# Contributor: Jake Buchholz <tomalok@gmail.com>
-# Maintainer: Jake Buchholz <tomalok@gmail.com>
+# Contributor: Jake Buchholz Göktürk <tomalok@gmail.com>
+# Maintainer: Jake Buchholz Göktürk <tomalok@gmail.com>
pkgname=go-md2man
-pkgver=2.0.0
+pkgver=2.0.4
pkgrel=1
pkgdesc="Utility to convert markdown to man pages"
-options="net chmod-clean"
+options="net"
url="https://github.com/cpuguy83/go-md2man"
arch="all"
license="MIT"
makedepends="go"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/cpuguy83/go-md2man/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/cpuguy83/go-md2man"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+export GOFLAGS="$GOFLAGS -modcacherw"
build() {
- cd "$srcdir"
- export GOPATH="$PWD"
- mkdir -p $(dirname "$builddir")
- ln -s "$PWD/go-md2man-$pkgver" "$builddir"
- cd $builddir
- CGO_ENABLED=0 go build
+ go build
+
+ ./go-md2man -in go-md2man.1.md -out go-md2man.1
}
check() {
- ./go-md2man -in go-md2man.1.md -out go-md2man.1
+ grep -q "User Manual" go-md2man.1
}
package() {
@@ -31,4 +33,6 @@ package() {
install -Dm644 go-md2man.1 "$pkgdir"/usr/share/man/man1/go-md2man.1
}
-sha512sums="22a6c950ca7e386246fadb15f05d0a60437a249df48a7c5f905bc4bd05034cede6318e1158bd2113e97b4fd2d1e838776680a00c6141ac2b3c8795aeee15a39d go-md2man-2.0.0.tar.gz"
+sha512sums="
+2169f16a7ea769357511a72dff5f8a5728ec810ed4165e6a4b8c61ee2fa7bccab132bad94584a547c5ce4c63ca533a144a6c379d81f1977854eb22bfbe21e065 go-md2man-2.0.4.tar.gz
+"