aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-task/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-task/APKBUILD')
-rw-r--r--community/go-task/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/community/go-task/APKBUILD b/community/go-task/APKBUILD
index 6d3798d0cd8..6ae9605aa02 100644
--- a/community/go-task/APKBUILD
+++ b/community/go-task/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=go-task
-pkgver=3.9.2
+pkgver=3.36.0
pkgrel=0
pkgdesc="Task runner written in Go, installed as go-task"
url="https://taskfile.dev/"
@@ -20,34 +20,35 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/go-task/task/archive/refs/ta
"
builddir="$srcdir/task-$pkgver"
-export GOPATH="$srcdir/go"
-export GOCACHE="$srcdir/go-build"
-export GOTMPDIR="$srcdir"
-
-export GOFLAGS="$GOFLAGS -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -v -ldflags="-X main.version=$pkgver" github.com/go-task/task/v3/cmd/task
}
check() {
+ go build -o bin/ ./cmd/sleepit
go test -v ./...
}
package() {
install -Dm0755 task "$pkgdir"/usr/bin/go-task
- install -Dm0644 docs/usage.md "$pkgdir"/usr/share/doc/go-task/usage.md
+ install -Dm0644 website/docs/usage.mdx -t "$pkgdir"/usr/share/doc/go-task/
install -Dm0644 completion/bash/task.bash \
"$pkgdir"/usr/share/bash-completion/completions/go-task.bash
install -Dm0644 completion/fish/task.fish \
- "$pkgdir"/usr/share/fish/completions/go-task.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/go-task.fish
install -Dm0644 completion/zsh/_task \
"$pkgdir"/usr/share/zsh/site-functions/_go_task
+
+ install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
}
task() {
- description="Task runner, written in Go, installed as task"
+ pkgdesc="Task runner, written in Go, installed as task"
depends="!task"
mkdir -p "$subpkgdir/usr/bin"
@@ -55,6 +56,6 @@ task() {
}
sha512sums="
-fbb9dcf39213939a2bbff1c851e831edc607d56f1a181396abc258b826a00fd07a4cee6077fdbbaa14179a51c574f9fdbaebe18998ba573527f2315ab7b6364e go-task-3.9.2.tar.gz
-84054b4a895ef3f5860e3e151d375d28cb278e1315c8d77876ba1523a745442c4ca5f27cead5655aeeb04013c9a35423e5ea36ccc7f45cb8bf2bb079857d71d1 completion-rename-to-go-task.patch
+7ab561cb3b5d26d6eda494d37f49d997eef6ac2fb1c8ff6aaa8540495e45640201bd2473bd52a0146283b34f2a9d6a199e8d97ddf6b1786d46566bb6f950879c go-task-3.36.0.tar.gz
+47b0d4270046bfba1871d37af4ebb6e38d2b1c7486085f2baeb7d3a8ee8b19f27f6366d436a41ed13215280e1e39bb8f8ac40d8ac7a6636fb20cd8c4d54ad187 completion-rename-to-go-task.patch
"