aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-task/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-task/APKBUILD')
-rw-r--r--community/go-task/APKBUILD30
1 files changed, 21 insertions, 9 deletions
diff --git a/community/go-task/APKBUILD b/community/go-task/APKBUILD
index 1ae0c73efcf..c27af2052c9 100644
--- a/community/go-task/APKBUILD
+++ b/community/go-task/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=go-task
-pkgver=3.7.3
-pkgrel=0
+pkgver=3.35.1
+pkgrel=1
pkgdesc="Task runner written in Go, installed as go-task"
url="https://taskfile.dev/"
arch="all"
@@ -10,6 +10,7 @@ license="MIT"
makedepends="go"
subpackages="
$pkgname-doc
+ $pkgname-task::noarch
$pkgname-bashcomp::noarch
$pkgname-fishcomp::noarch
$pkgname-zshcomp::noarch
@@ -19,9 +20,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/go-task/task/archive/refs/ta
"
builddir="$srcdir/task-$pkgver"
-export GOPATH="$srcdir/go"
-export GOCACHE="$srcdir/go-build"
-export GOTMPDIR="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
export GOFLAGS="$GOFLAGS -modcacherw"
@@ -30,22 +31,33 @@ build() {
}
check() {
+ go build -o bin/ ./cmd/sleepit
go test -v ./...
}
package() {
install -Dm0755 task "$pkgdir"/usr/bin/go-task
- install -Dm0644 docs/usage.md "$pkgdir"/usr/share/doc/go-task/usage.md
+ install -Dm0644 docs/docs/usage.md "$pkgdir"/usr/share/doc/go-task/usage.md
install -Dm0644 completion/bash/task.bash \
"$pkgdir"/usr/share/bash-completion/completions/go-task.bash
install -Dm0644 completion/fish/task.fish \
- "$pkgdir"/usr/share/fish/completions/go-task.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/go-task.fish
install -Dm0644 completion/zsh/_task \
"$pkgdir"/usr/share/zsh/site-functions/_go_task
+
+ install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+}
+
+task() {
+ pkgdesc="Task runner, written in Go, installed as task"
+ depends="!task"
+
+ mkdir -p "$subpkgdir/usr/bin"
+ ln -s /usr/bin/go-task "$subpkgdir/usr/bin/task"
}
sha512sums="
-164e4f4fe4483d15081b90032151a624907050ab0d6e7328a636159380ed60a4fcf012ec9eb169d5976a7836d6e395e26b59c0d588833122c318c8618fa61841 go-task-3.7.3.tar.gz
-84054b4a895ef3f5860e3e151d375d28cb278e1315c8d77876ba1523a745442c4ca5f27cead5655aeeb04013c9a35423e5ea36ccc7f45cb8bf2bb079857d71d1 completion-rename-to-go-task.patch
+a5ffcaf3ad96a57840b9e6bdfd9e585cb8f64db377da74db0c77cda809c0bfc1b07f31e2b35ef83f72607b3fcd15f0f9bcec5274f27b9bcf4694da2e2c76b6dd go-task-3.35.1.tar.gz
+47b0d4270046bfba1871d37af4ebb6e38d2b1c7486085f2baeb7d3a8ee8b19f27f6366d436a41ed13215280e1e39bb8f8ac40d8ac7a6636fb20cd8c4d54ad187 completion-rename-to-go-task.patch
"