aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-task/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-task/APKBUILD')
-rw-r--r--community/go-task/APKBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/community/go-task/APKBUILD b/community/go-task/APKBUILD
index dc01e3a567f..6ae9605aa02 100644
--- a/community/go-task/APKBUILD
+++ b/community/go-task/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=go-task
-pkgver=3.14.1
+pkgver=3.36.0
pkgrel=0
pkgdesc="Task runner written in Go, installed as go-task"
url="https://taskfile.dev/"
@@ -20,11 +20,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/go-task/task/archive/refs/ta
"
builddir="$srcdir/task-$pkgver"
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
-
-export GOFLAGS="$GOFLAGS -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -v -ldflags="-X main.version=$pkgver" github.com/go-task/task/v3/cmd/task
@@ -37,14 +35,16 @@ check() {
package() {
install -Dm0755 task "$pkgdir"/usr/bin/go-task
- install -Dm0644 docs/docs/usage.md "$pkgdir"/usr/share/doc/go-task/usage.md
+ install -Dm0644 website/docs/usage.mdx -t "$pkgdir"/usr/share/doc/go-task/
install -Dm0644 completion/bash/task.bash \
"$pkgdir"/usr/share/bash-completion/completions/go-task.bash
install -Dm0644 completion/fish/task.fish \
- "$pkgdir"/usr/share/fish/completions/go-task.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/go-task.fish
install -Dm0644 completion/zsh/_task \
"$pkgdir"/usr/share/zsh/site-functions/_go_task
+
+ install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
}
task() {
@@ -56,6 +56,6 @@ task() {
}
sha512sums="
-511c28a1e6523c0cc9c1d551593e3661e9bc9d9778754948391561b06cbbfdc95f0227f7b3a540c6c6a702596adc1fae6ef708e2b45c47893e3e8b90b8e5e9cf go-task-3.14.1.tar.gz
-ef909580b18341b6b7a5e21d3a8d3331f5a0de6dd05d2ba63b1f11c21dd54676eb277c9df88673fab1a654706dae3298f758e534e4237c42da7bcd6ac78d25cd completion-rename-to-go-task.patch
+7ab561cb3b5d26d6eda494d37f49d997eef6ac2fb1c8ff6aaa8540495e45640201bd2473bd52a0146283b34f2a9d6a199e8d97ddf6b1786d46566bb6f950879c go-task-3.36.0.tar.gz
+47b0d4270046bfba1871d37af4ebb6e38d2b1c7486085f2baeb7d3a8ee8b19f27f6366d436a41ed13215280e1e39bb8f8ac40d8ac7a6636fb20cd8c4d54ad187 completion-rename-to-go-task.patch
"