aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-task/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go-task/APKBUILD')
-rw-r--r--community/go-task/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/go-task/APKBUILD b/community/go-task/APKBUILD
index a42829dc6c5..6ae9605aa02 100644
--- a/community/go-task/APKBUILD
+++ b/community/go-task/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=go-task
-pkgver=3.10.0
+pkgver=3.36.0
pkgrel=0
pkgdesc="Task runner written in Go, installed as go-task"
url="https://taskfile.dev/"
@@ -20,30 +20,31 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/go-task/task/archive/refs/ta
"
builddir="$srcdir/task-$pkgver"
-export GOPATH="$srcdir/go"
-export GOCACHE="$srcdir/go-build"
-export GOTMPDIR="$srcdir"
-
-export GOFLAGS="$GOFLAGS -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -v -ldflags="-X main.version=$pkgver" github.com/go-task/task/v3/cmd/task
}
check() {
+ go build -o bin/ ./cmd/sleepit
go test -v ./...
}
package() {
install -Dm0755 task "$pkgdir"/usr/bin/go-task
- install -Dm0644 docs/usage.md "$pkgdir"/usr/share/doc/go-task/usage.md
+ install -Dm0644 website/docs/usage.mdx -t "$pkgdir"/usr/share/doc/go-task/
install -Dm0644 completion/bash/task.bash \
"$pkgdir"/usr/share/bash-completion/completions/go-task.bash
install -Dm0644 completion/fish/task.fish \
- "$pkgdir"/usr/share/fish/completions/go-task.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/go-task.fish
install -Dm0644 completion/zsh/_task \
"$pkgdir"/usr/share/zsh/site-functions/_go_task
+
+ install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
}
task() {
@@ -55,6 +56,6 @@ task() {
}
sha512sums="
-eb28f599e31f30d79ee74352e1607f3554035b3db33752fdf97cad54189eb54f4a25b483e696feb7403138265a67118112006e13a60708ba1416290f946b464a go-task-3.10.0.tar.gz
-ed78b6ee7c7db13ba002766e5798ad66c770317670fbf74bcae6a8eab3c963ff4c2894e36e2632e51355047021e1e5e8bf06c8b57247e1b7207958c43732317f completion-rename-to-go-task.patch
+7ab561cb3b5d26d6eda494d37f49d997eef6ac2fb1c8ff6aaa8540495e45640201bd2473bd52a0146283b34f2a9d6a199e8d97ddf6b1786d46566bb6f950879c go-task-3.36.0.tar.gz
+47b0d4270046bfba1871d37af4ebb6e38d2b1c7486085f2baeb7d3a8ee8b19f27f6366d436a41ed13215280e1e39bb8f8ac40d8ac7a6636fb20cd8c4d54ad187 completion-rename-to-go-task.patch
"