aboutsummaryrefslogtreecommitdiffstats
path: root/community/goimapnotify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/goimapnotify/APKBUILD')
-rw-r--r--community/goimapnotify/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/community/goimapnotify/APKBUILD b/community/goimapnotify/APKBUILD
index 40b547a14e2..f1975a8ed25 100644
--- a/community/goimapnotify/APKBUILD
+++ b/community/goimapnotify/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Contributor: Thomas Böhler <witcher@wiredspace.de>
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=goimapnotify
-pkgver=2.3.7
-pkgrel=1
+pkgver=2.3.12
+pkgrel=0
pkgdesc="execute scripts on IMAP mailbox changes using IDLE, golang version"
url="https://gitlab.com/shackra/goimapnotify"
arch="all"
@@ -11,6 +12,10 @@ makedepends="go"
options="net"
source="https://gitlab.com/shackra/goimapnotify/-/archive/$pkgver/goimapnotify-$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CFLAGS="$CFLAGS"
@@ -23,7 +28,7 @@ build() {
golang.org/x/sys=golang.org/x/sys@v0.0.0-20210630005230-0f9fa26af87c
go mod download golang.org/x/sys
- go build -ldflags "-linkmode=external -extldflags=$LDFLAGS"
+ go build -ldflags "-linkmode=external \"-extldflags=$LDFLAGS\""
}
check() {
@@ -33,8 +38,10 @@ check() {
package() {
install -Dm755 goimapnotify "$pkgdir"/usr/bin/goimapnotify
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
+ install -Dm644 CHANGELOG.rst "$pkgdir"/usr/share/doc/"$pkgname"/CHANGELOG.rst
}
sha512sums="
-7551ec498c3414448b21bf4202a69bbab8815dd9423638b3adbf31fb2857a008fb6f1ac78e41ce695550931dfe4ba9c49050f3bfcab2d646f37547a7efcdaff7 goimapnotify-2.3.7.tar.gz
+c3061af4df07dc2e58b338b25a933b9bd31693e2a8a50fe7f6dcc921f8ee48975d97d9c3f9bea1804f3f6e2a0f282984d72152e7cc3e57a8485300369819461f goimapnotify-2.3.12.tar.gz
"