aboutsummaryrefslogtreecommitdiffstats
path: root/community/gojq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gojq/APKBUILD')
-rw-r--r--community/gojq/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/gojq/APKBUILD b/community/gojq/APKBUILD
index 3168b644da0..5ce4c3a46df 100644
--- a/community/gojq/APKBUILD
+++ b/community/gojq/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=gojq
-pkgver=0.12.8
+pkgver=0.12.15
pkgrel=0
pkgdesc="Pure Go implementation of jq"
url="https://github.com/itchyny/gojq"
@@ -9,14 +9,16 @@ license="MIT"
arch="all"
makedepends="go"
subpackages="$pkgname-zsh-completion"
-source="https://github.com/itchyny/gojq/archive/v$pkgver/gojq-$pkgver.tar.gz"
+source="https://github.com/itchyny/gojq/archive/v$pkgver/gojq-$pkgver.tar.gz
+ fix-tests.patch
+ "
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -ldflags "-s -w" ./cmd/gojq
+ go build ./cmd/gojq
}
check() {
@@ -24,11 +26,12 @@ check() {
}
package() {
- install -Dm755 gojq -t "$pkgdir"/usr/bin
+ install -Dm755 gojq -t "$pkgdir"/usr/bin/
- install -Dm644 _gojq -t "$pkgdir"/usr/share/zsh/site-functions
+ install -Dm644 _gojq -t "$pkgdir"/usr/share/zsh/site-functions/
}
sha512sums="
-079573d0fab28abbbd66ea256544b06927a5739e25faf2cc2f3172bedfbfd60f8ac98bed0dfa08b6a31d421f2614603e2943799634383732e7a17300fa9617b4 gojq-0.12.8.tar.gz
+55c0d5b5f3a19e8a98bc6e6e23ab9e88670d94df48bb098e2e0dd888b201891d2482aacf771cb6a274ee259faec1f3da022431ac70dc2e509fe4da4ab47762bf gojq-0.12.15.tar.gz
+420549483a750a08d3e69f92a3a4f60960fc5b31c0226acfeecbf48130b32372b2d563c937798e41f660487983939c331045a8d319831bb0304c4f0d23fe28ba fix-tests.patch
"