aboutsummaryrefslogtreecommitdiffstats
path: root/community/gojq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gojq/APKBUILD')
-rw-r--r--community/gojq/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/community/gojq/APKBUILD b/community/gojq/APKBUILD
index ee43cc053ef..5ce4c3a46df 100644
--- a/community/gojq/APKBUILD
+++ b/community/gojq/APKBUILD
@@ -1,21 +1,21 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=gojq
-pkgver=0.12.3
+pkgver=0.12.15
pkgrel=0
pkgdesc="Pure Go implementation of jq"
url="https://github.com/itchyny/gojq"
license="MIT"
arch="all"
-options="chmod-clean"
makedepends="go"
subpackages="$pkgname-zsh-completion"
source="https://github.com/itchyny/gojq/archive/v$pkgver/gojq-$pkgver.tar.gz
- fix-modulo-tests.patch
+ fix-tests.patch
"
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build ./cmd/gojq
@@ -26,10 +26,12 @@ check() {
}
package() {
- install -Dm755 gojq "$pkgdir"/usr/bin/$pkgname
+ install -Dm755 gojq -t "$pkgdir"/usr/bin/
- install -Dm755 _gojq "$pkgdir"/usr/share/zsh/site-functions/_gojq
+ install -Dm644 _gojq -t "$pkgdir"/usr/share/zsh/site-functions/
}
-sha512sums="8495691d649b4e4ed9d258f006456c7b134941cd84b1b3046e0943b021382dfed324718e3c90929159bd4e63ae2d71c70920be60d1a8a405482e597f65dcbf5a gojq-0.12.3.tar.gz
-1785dc82740c047db68d7cf0697c2eca5b709a667784f782ed7807b632f4cea2bec8b185146482d8c7699717c077f8166a86254623987f21caa25cfef3505c79 fix-modulo-tests.patch"
+sha512sums="
+55c0d5b5f3a19e8a98bc6e6e23ab9e88670d94df48bb098e2e0dd888b201891d2482aacf771cb6a274ee259faec1f3da022431ac70dc2e509fe4da4ab47762bf gojq-0.12.15.tar.gz
+420549483a750a08d3e69f92a3a4f60960fc5b31c0226acfeecbf48130b32372b2d563c937798e41f660487983939c331045a8d319831bb0304c4f0d23fe28ba fix-tests.patch
+"