aboutsummaryrefslogtreecommitdiffstats
path: root/community/gojq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gojq/APKBUILD')
-rw-r--r--community/gojq/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/gojq/APKBUILD b/community/gojq/APKBUILD
index e01e4e3a3f3..5ce4c3a46df 100644
--- a/community/gojq/APKBUILD
+++ b/community/gojq/APKBUILD
@@ -1,19 +1,21 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=gojq
-pkgver=0.12.5
-pkgrel=1
+pkgver=0.12.15
+pkgrel=0
pkgdesc="Pure Go implementation of jq"
url="https://github.com/itchyny/gojq"
license="MIT"
arch="all"
-options="chmod-clean"
makedepends="go"
subpackages="$pkgname-zsh-completion"
-source="https://github.com/itchyny/gojq/archive/v$pkgver/gojq-$pkgver.tar.gz"
+source="https://github.com/itchyny/gojq/archive/v$pkgver/gojq-$pkgver.tar.gz
+ fix-tests.patch
+ "
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build ./cmd/gojq
@@ -24,11 +26,12 @@ check() {
}
package() {
- install -Dm755 gojq "$pkgdir"/usr/bin/$pkgname
+ install -Dm755 gojq -t "$pkgdir"/usr/bin/
- install -Dm755 _gojq "$pkgdir"/usr/share/zsh/site-functions/_gojq
+ install -Dm644 _gojq -t "$pkgdir"/usr/share/zsh/site-functions/
}
sha512sums="
-8d8e3fa10cbacfa86f8a7ebfb7da7d0236789235b22bbc94cd8be865bb9de0b7ed6bd9c53d6f9df2c6c53a1bdbf3c509ea8e54aa5c1f9435332d1391eb36992c gojq-0.12.5.tar.gz
+55c0d5b5f3a19e8a98bc6e6e23ab9e88670d94df48bb098e2e0dd888b201891d2482aacf771cb6a274ee259faec1f3da022431ac70dc2e509fe4da4ab47762bf gojq-0.12.15.tar.gz
+420549483a750a08d3e69f92a3a4f60960fc5b31c0226acfeecbf48130b32372b2d563c937798e41f660487983939c331045a8d319831bb0304c4f0d23fe28ba fix-tests.patch
"