aboutsummaryrefslogtreecommitdiffstats
path: root/community/gom/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gom/APKBUILD')
-rw-r--r--community/gom/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/gom/APKBUILD b/community/gom/APKBUILD
index 1478f72bda4..48cf1c905d7 100644
--- a/community/gom/APKBUILD
+++ b/community/gom/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gom
pkgver=0.4
-pkgrel=2
+pkgrel=6
pkgdesc="GObject Data Mapper"
url="https://wiki.gnome.org/Projects/Gom"
arch="all"
@@ -12,9 +12,12 @@ makedepends="meson vala gobject-introspection-dev py3-gobject3 sqlite-dev glib-d
subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/gom/$pkgver/gom-$pkgver.tar.xz"
+# gom-stress seems to segfault with new glib
+options="!check"
+
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
@@ -26,4 +29,6 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="d847928ce09c53a3f64777c313cb843052e5e001873f29d3f7acf02772cadf0e4b133fb0137aa0463b4ff95dd54810bde87062d8e396ff4fc6d142ba59c8e9c8 gom-0.4.tar.xz"
+sha512sums="
+d847928ce09c53a3f64777c313cb843052e5e001873f29d3f7acf02772cadf0e4b133fb0137aa0463b4ff95dd54810bde87062d8e396ff4fc6d142ba59c8e9c8 gom-0.4.tar.xz
+"