aboutsummaryrefslogtreecommitdiffstats
path: root/community/gomplate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gomplate/APKBUILD')
-rw-r--r--community/gomplate/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/community/gomplate/APKBUILD b/community/gomplate/APKBUILD
index a7b190424b5..a67d0093ef8 100644
--- a/community/gomplate/APKBUILD
+++ b/community/gomplate/APKBUILD
@@ -1,19 +1,29 @@
# Maintainer: Dave Henderson <dhenderson@gmail.com>
pkgname=gomplate
-pkgver=3.11.2
-pkgrel=0
+pkgver=3.11.7
+pkgrel=3
pkgdesc="A versatile Go template processor"
url="https://github.com/hairyhenderson/gomplate"
-arch="all !s390x" # FAIL: TestCreateContext with SIGSEGV
+arch="all"
license="MIT"
depends="ca-certificates"
makedepends="go"
+options="net"
source="$pkgname-$pkgver.tar.gz::https://github.com/hairyhenderson/gomplate/archive/v$pkgver.tar.gz"
export GOFLAGS="$GOFLAGS -trimpath -modcacherw"
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+prepare() {
+ default_prepare
+
+ # Fix build with -buildmode=pie.
+ #
+ # See: https://gitlab.alpinelinux.org/alpine/aports/-/issues/15809
+ sed -i Makefile -e 's/CGO_ENABLED=0//'
+}
build() {
make build \
@@ -30,6 +40,4 @@ package() {
install -D -m 755 bin/gomplate "$pkgdir"/usr/bin/gomplate
}
-sha512sums="
-86ec3cd0246f0af57f8c88aaa2cb971bfe3f1c2b869cf9655f49003693bea071cf428b8987a4b2f9ffd5929922bcb98c6f7bd9ef6dcc28b5deadc458e0064fc4 gomplate-3.11.2.tar.gz
-"
+sha512sums="91646e4142bd49fef408d437c8f744f16fc3a13eddfcc7da45309b3200ae5b49cb3b2363e2f89744deff01d0370979aec6c3f20249a422ddd17b0e0ce72f9a5f gomplate-3.11.7.tar.gz"