aboutsummaryrefslogtreecommitdiffstats
path: root/community/gomplate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gomplate/APKBUILD')
-rw-r--r--community/gomplate/APKBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/community/gomplate/APKBUILD b/community/gomplate/APKBUILD
index 98d01906ca2..a67d0093ef8 100644
--- a/community/gomplate/APKBUILD
+++ b/community/gomplate/APKBUILD
@@ -1,43 +1,43 @@
# Maintainer: Dave Henderson <dhenderson@gmail.com>
pkgname=gomplate
-_goname="github.com/hairyhenderson/$pkgname"
-pkgver=3.9.0
-pkgrel=1
+pkgver=3.11.7
+pkgrel=3
pkgdesc="A versatile Go template processor"
url="https://github.com/hairyhenderson/gomplate"
-arch="all !s390x" # FAIL: TestCreateContext with SIGSEGV
+arch="all"
license="MIT"
depends="ca-certificates"
makedepends="go"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/$_goname"
+options="net"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hairyhenderson/gomplate/archive/v$pkgver.tar.gz"
-prepare() {
- mkdir -p "${builddir%/*}"
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+export GOFLAGS="$GOFLAGS -trimpath -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+prepare() {
default_prepare
+
+ # Fix build with -buildmode=pie.
+ #
+ # See: https://gitlab.alpinelinux.org/alpine/aports/-/issues/15809
+ sed -i Makefile -e 's/CGO_ENABLED=0//'
}
build() {
make build \
- GOPATH="$srcdir" \
VERSION="$pkgver" \
COMMIT="unknown"
}
check() {
# Note: make test (that runs go test -race) doesn't work.
- GOPATH="$srcdir" go test -v
+ go test -v
}
package() {
install -D -m 755 bin/gomplate "$pkgdir"/usr/bin/gomplate
}
-cleanup_srcdir() {
- [ -d src ] && chmod -R +w src
- default_cleanup_srcdir
-}
-
-sha512sums="7716d24be60f627f0833c47f416a8e3a20dfc2a38fc427d6e06cbcd34383c8792894c6539462b886048501fcb88050b0afcd0e2fce11646bb30fbf716770354c gomplate-3.9.0.tar.gz"
+sha512sums="91646e4142bd49fef408d437c8f744f16fc3a13eddfcc7da45309b3200ae5b49cb3b2363e2f89744deff01d0370979aec6c3f20249a422ddd17b0e0ce72f9a5f gomplate-3.11.7.tar.gz"