aboutsummaryrefslogtreecommitdiffstats
path: root/community/gomuks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gomuks/APKBUILD')
-rw-r--r--community/gomuks/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/gomuks/APKBUILD b/community/gomuks/APKBUILD
new file mode 100644
index 00000000000..eae77b5efb9
--- /dev/null
+++ b/community/gomuks/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Julian Weigt <juw@posteo.de>
+# Contributor: Maxim Karasev <mxkrsv@disroot.org>
+# Maintainer: Julian Weigt <juw@posteo.de>
+pkgname=gomuks
+pkgver=0.3.0
+pkgrel=12
+pkgdesc="terminal-based Matrix client written in Go"
+url="https://github.com/tulir/gomuks"
+arch="all"
+license="AGPL-3.0-or-later"
+depends="ncurses"
+makedepends="go olm-dev sqlite-dev"
+subpackages="$pkgname-doc"
+options="!check" # no test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/tulir/gomuks/archive/v$pkgver.tar.gz"
+
+export GOFLAGS="$GOFLAGS -tags=libsqlite3"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ go build
+}
+
+package() {
+ install -Dm755 gomuks "$pkgdir/usr/bin/gomuks"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+sha512sums="
+9f001db7b926779f4f33dd0fa3c5d4a88ec31862ecbcfd529846b187d3ac26f70d2836250bc827a8852b8af62a32a3e2e20861f849cfa2d39bf1784967c4c80a gomuks-0.3.0.tar.gz
+"