aboutsummaryrefslogtreecommitdiffstats
path: root/community/gonic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gonic/APKBUILD')
-rw-r--r--community/gonic/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/gonic/APKBUILD b/community/gonic/APKBUILD
index 01a47661a4c..de75e2db426 100644
--- a/community/gonic/APKBUILD
+++ b/community/gonic/APKBUILD
@@ -1,24 +1,29 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=gonic
-pkgver=0.14.0
-pkgrel=0
+pkgver=0.16.2
+pkgrel=2
pkgdesc="Subsonic compatible music streaming server"
url="https://github.com/sentriz/gonic"
arch="all"
license="GPL-3.0-or-later"
subpackages="$pkgname-openrc"
-depends="ffmpeg sqlite"
-makedepends="go alsa-lib-dev taglib-dev zlib-dev"
+depends="ffmpeg"
+makedepends="go taglib-dev zlib-dev sqlite-dev"
install="$pkgname.pre-install"
source="gonic-$pkgver.tar.gz::https://github.com/sentriz/gonic/archive/v$pkgver.tar.gz
gonic.initd
gonic.confd
"
-export GOPATH="$srcdir"
+options="!check" # intermittent test failure
+
export GO111MODULES=on
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
+ export GOFLAGS="$GOFLAGS -tags=libsqlite3"
go build -o gonic ./cmd/gonic/gonic.go
}
@@ -41,9 +46,8 @@ cleanup_srcdir() {
default_cleanup_srcdir
}
-
sha512sums="
-b518b42e102d834ba04d82f5e4a64f38cb6a1d6b34a025f3f76c4a571ff377c1566c6126c8de9e69440c5420a2091070713f9a6e5b4ad5ae51bb8170cacd2ba9 gonic-0.14.0.tar.gz
+3d42be96b1381b58a44779e71294c4380c3005d22876b848d3f85bba5687f954883be45cda37ad40c147a64b4317566b3d647767375a76cd03c8311a26a1c972 gonic-0.16.2.tar.gz
e8a65612bffd1b62175968cc34a227393364ea6fedd661854bf515cc7306e9266d823544989b671f99beb72b6caf83728fa7c7fd9eedbc85a3e34ea84c1ce269 gonic.initd
-bce2f839f98e2b66010f14e52265a061644867109e43062672bdf3850de51ab8d7b61ea38d7f223de25cf91105ef441b0c1969afc812763702397ed60c0fba4f gonic.confd
+b72e31c0f9f79694736aadb8ca581fdb269e82ece9f2c8e45cdb4edb3e01c7fd140e65c11be65cc242dddb273c8c93fde2af12a32241d7936318f3c3cd73d2ec gonic.confd
"