aboutsummaryrefslogtreecommitdiffstats
path: root/community/goobook/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/goobook/APKBUILD')
-rw-r--r--community/goobook/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/community/goobook/APKBUILD b/community/goobook/APKBUILD
index bb644f4528d..3407a5c1ef5 100644
--- a/community/goobook/APKBUILD
+++ b/community/goobook/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
# Maintainer:
pkgname=goobook
-pkgver=3.5.1
-pkgrel=0
+pkgver=3.5.2
+pkgrel=3
pkgdesc="Access Google contacts from the command line"
url="https://gitlab.com/goobook/goobook"
arch="noarch !ppc64le" # limited by py3-grpcio
@@ -12,27 +12,31 @@ depends="
py3-google-auth-httplib2
py3-httplib2
py3-oauth2client
+ py3-setuptools
py3-simplejson
py3-xdg
python3
"
-makedepends="py3-docutils py3-setuptools"
+makedepends="py3-docutils py3-gpep517 py3-poetry-core"
options="!check" # no test suite on gitlab
-subpackages="$pkgname-doc"
-source="https://files.pythonhosted.org/packages/source/g/goobook/goobook-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="https://gitlab.com/goobook/goobook/-/archive/$pkgver/goobook-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
- rst2man-3 --strict goobook.1.rst goobook.1
+ rst2man --strict goobook.1.rst goobook.1
}
package() {
- python3 setup.py install --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/goobook-*.whl
install -Dm644 goobook.1 -t "$pkgdir"/usr/share/man/man1
}
sha512sums="
-58d056d7d76843bc874e55424912bb00068541e674b780511b7753da31f2df9514baa188017dd0a7479b5527cd50c47e35f37afc493bdc973e0eb1624998a611 goobook-3.5.1.tar.gz
+f9f824100e948010e9fb25c79ea035259dc53ce4b123b3c5251ea6cc58b27914b2b45235c08b2237fc80fd3e9f9ee8505670702f1e7dcf7387e862104cdef557 goobook-3.5.2.tar.gz
"