aboutsummaryrefslogtreecommitdiffstats
path: root/community/goobook/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/goobook/APKBUILD')
-rw-r--r--community/goobook/APKBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/community/goobook/APKBUILD b/community/goobook/APKBUILD
index 503dac57c28..4ff58fa5aac 100644
--- a/community/goobook/APKBUILD
+++ b/community/goobook/APKBUILD
@@ -1,29 +1,42 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
-# Maintainer: Ivan Tham <pickfire@riseup.net>
+# Maintainer:
pkgname=goobook
-pkgver=3.5
+pkgver=3.5.2
pkgrel=2
pkgdesc="Access Google contacts from the command line"
url="https://gitlab.com/goobook/goobook"
arch="noarch !ppc64le" # limited by py3-grpcio
license="GPL-3.0-or-later"
-depends="py3-httplib2 py3-google-auth-httplib2
- py3-google-api-python-client py3-simplejson py3-oauth2client"
-makedepends="py3-docutils py3-setuptools"
+depends="
+ py3-google-api-python-client
+ py3-google-auth-httplib2
+ py3-httplib2
+ py3-oauth2client
+ py3-setuptools
+ py3-simplejson
+ py3-xdg
+ python3
+ "
+makedepends="py3-docutils py3-gpep517 py3-poetry-core"
options="!check" # no test suite on gitlab
-subpackages="$pkgname-doc"
-source="https://files.pythonhosted.org/packages/source/g/goobook/goobook-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="https://gitlab.com/goobook/goobook/-/archive/$pkgver/goobook-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
- rst2man-3 --strict goobook.1.rst goobook.1
+ rst2man --strict goobook.1.rst goobook.1
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/goobook-*.whl
- install -D -m0644 goobook.1 "$pkgdir/usr/share/man/man1/goobook.1"
+ install -Dm644 goobook.1 -t "$pkgdir"/usr/share/man/man1
}
-sha512sums="96c9fac3eab78456e694339fd0e7f6965d6603a0531a41e07749a2468317d4fa191c7a1a54abdb256ab6d1196bc645a285bbdaa0e2a080980fe86b6976a84a82 goobook-3.5.tar.gz"
+sha512sums="
+f9f824100e948010e9fb25c79ea035259dc53ce4b123b3c5251ea6cc58b27914b2b45235c08b2237fc80fd3e9f9ee8505670702f1e7dcf7387e862104cdef557 goobook-3.5.2.tar.gz
+"