aboutsummaryrefslogtreecommitdiffstats
path: root/community/gopass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gopass/APKBUILD')
-rw-r--r--community/gopass/APKBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/community/gopass/APKBUILD b/community/gopass/APKBUILD
index edb45ad4c9d..6f4c82a1405 100644
--- a/community/gopass/APKBUILD
+++ b/community/gopass/APKBUILD
@@ -2,16 +2,17 @@
# Contributor: Claas Störtenbecker <claas.stoertenbecker@gmail.com>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=gopass
-pkgver=1.12.8
-pkgrel=2
+pkgver=1.15.12
+pkgrel=0
pkgdesc="The slightly more awesome Standard Unix Password Manager for Teams. Written in Go."
url="https://www.gopass.pw"
arch="all"
license="MIT"
depends="gnupg git"
makedepends="go ncurses"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz"
-options="chmod-clean"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz
+ enable-cgo.patch"
+options="chmod-clean net"
subpackages="
$pkgname-bash-completion
$pkgname-zsh-completion
@@ -19,20 +20,26 @@ subpackages="
$pkgname-doc
"
-check() {
- GOPATH="$srcdir" make test-integration
-}
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- GOPATH="$srcdir" make build BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+ make build BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+}
+
+check() {
+ # This fails if user already has a ~/.password-store
+ make test-integration
}
package() {
- GOPATH="$srcdir" make install DESTDIR="$pkgdir" PREFIX="/usr" BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+ make install DESTDIR="$pkgdir" PREFIX="/usr" BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
install -Dm0644 "$builddir"/fish.completion \
- "$pkgdir"/usr/share/fish/completions/gopass.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/gopass.fish
}
sha512sums="
-df82bba2ff59c1f7e2f8b416ad63672fc876469978c61ad514021e0b46d136c78bfd4e4c68ee54c01ba8b82d599f4ab4d89c3df1857f84ecde7392943a406ac1 gopass-1.12.8.tar.gz
+09359ee0006a4e0cd7feb45b67e77192208dbabbd590f4c67de222159dad1ea44a73381e2edd1928d0205d771b3116a65652e802cf61890fe58955601e76a5e0 gopass-1.15.12.tar.gz
+0866b5378abc1c621d188c5dd6afe25841dd1459f176543f93d319c0e041e701a80e0d51c1977d2e6ed892b38730248217b2c9c7c53f3dddaa155f5c2a311456 enable-cgo.patch
"