aboutsummaryrefslogtreecommitdiffstats
path: root/community/gopass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gopass/APKBUILD')
-rw-r--r--community/gopass/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/gopass/APKBUILD b/community/gopass/APKBUILD
index a2fbb071bd8..6f4c82a1405 100644
--- a/community/gopass/APKBUILD
+++ b/community/gopass/APKBUILD
@@ -2,15 +2,16 @@
# Contributor: Claas Störtenbecker <claas.stoertenbecker@gmail.com>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=gopass
-pkgver=1.14.3
-pkgrel=2
+pkgver=1.15.12
+pkgrel=0
pkgdesc="The slightly more awesome Standard Unix Password Manager for Teams. Written in Go."
url="https://www.gopass.pw"
arch="all"
license="MIT"
depends="gnupg git"
makedepends="go ncurses"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz
+ enable-cgo.patch"
options="chmod-clean net"
subpackages="
$pkgname-bash-completion
@@ -19,9 +20,9 @@ subpackages="
$pkgname-doc
"
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
make build BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
@@ -35,9 +36,10 @@ check() {
package() {
make install DESTDIR="$pkgdir" PREFIX="/usr" BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
install -Dm0644 "$builddir"/fish.completion \
- "$pkgdir"/usr/share/fish/completions/gopass.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/gopass.fish
}
sha512sums="
-bbb3257100f8413e2f249949c2a88cccbddfc1be4bff6cfa46576d7f714c78fcd022067550caadb71b9a0b27d4ad745efcce0c5d93f381cd1ce66fb8af30511f gopass-1.14.3.tar.gz
+09359ee0006a4e0cd7feb45b67e77192208dbabbd590f4c67de222159dad1ea44a73381e2edd1928d0205d771b3116a65652e802cf61890fe58955601e76a5e0 gopass-1.15.12.tar.gz
+0866b5378abc1c621d188c5dd6afe25841dd1459f176543f93d319c0e041e701a80e0d51c1977d2e6ed892b38730248217b2c9c7c53f3dddaa155f5c2a311456 enable-cgo.patch
"