aboutsummaryrefslogtreecommitdiffstats
path: root/community/gopass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gopass/APKBUILD')
-rw-r--r--community/gopass/APKBUILD40
1 files changed, 18 insertions, 22 deletions
diff --git a/community/gopass/APKBUILD b/community/gopass/APKBUILD
index 7094a87d3a6..f23edd255f0 100644
--- a/community/gopass/APKBUILD
+++ b/community/gopass/APKBUILD
@@ -2,17 +2,17 @@
# Contributor: Claas Störtenbecker <claas.stoertenbecker@gmail.com>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=gopass
-pkgver=1.12.6
-pkgrel=1
+pkgver=1.15.13
+pkgrel=0
pkgdesc="The slightly more awesome Standard Unix Password Manager for Teams. Written in Go."
url="https://www.gopass.pw"
arch="all"
license="MIT"
depends="gnupg git"
makedepends="go ncurses"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/gopasspw/$pkgname"
-options="chmod-clean"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz
+ enable-cgo.patch"
+options="chmod-clean net"
subpackages="
$pkgname-bash-completion
$pkgname-zsh-completion
@@ -20,30 +20,26 @@ subpackages="
$pkgname-doc
"
-case $CARCH in
- mips64)
- export GOFLAGS="${GOFLAGS/-buildmode=pie}" # buildmode=pie is not supported on mips64
- ;;
-esac
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
-prepare() {
- mkdir -p "$srcdir/src/github.com/gopasspw"
- mv "$srcdir/$pkgname-$pkgver" "$srcdir/src/github.com/gopasspw/gopass"
- default_prepare
+build() {
+ make build BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
}
check() {
- GOPATH="$srcdir" make test-integration
-}
-
-build() {
- GOPATH="$srcdir" make build BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+ # This fails if user already has a ~/.password-store
+ make test-integration
}
package() {
- GOPATH="$srcdir" make install DESTDIR="$pkgdir" PREFIX="/usr" BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+ make install DESTDIR="$pkgdir" PREFIX="/usr" BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
install -Dm0644 "$builddir"/fish.completion \
- "$pkgdir"/usr/share/fish/completions/gopass.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/gopass.fish
}
-sha512sums="2e237d1135e79e0236091dac38329ce39aad901fa016366f618d92ddc61246f7496d73d8b7fc4e9e5cb723b60c7798736eb2359a3da5ac1a7dce6fa9bb63ae1b gopass-1.12.6.tar.gz"
+sha512sums="
+b7fcc7814ccad0cf0e3116eac848df080338e313ddcbb0cc8413cb353a1596b250aed427c97e791326e04c6c4241dbb529e112398218f2a905fc0fb48bc49963 gopass-1.15.13.tar.gz
+0866b5378abc1c621d188c5dd6afe25841dd1459f176543f93d319c0e041e701a80e0d51c1977d2e6ed892b38730248217b2c9c7c53f3dddaa155f5c2a311456 enable-cgo.patch
+"