aboutsummaryrefslogtreecommitdiffstats
path: root/community/gopass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gopass/APKBUILD')
-rw-r--r--community/gopass/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/community/gopass/APKBUILD b/community/gopass/APKBUILD
index c5d4e0add1d..6f4c82a1405 100644
--- a/community/gopass/APKBUILD
+++ b/community/gopass/APKBUILD
@@ -2,16 +2,17 @@
# Contributor: Claas Störtenbecker <claas.stoertenbecker@gmail.com>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=gopass
-pkgver=1.13.1
-pkgrel=1
+pkgver=1.15.12
+pkgrel=0
pkgdesc="The slightly more awesome Standard Unix Password Manager for Teams. Written in Go."
url="https://www.gopass.pw"
arch="all"
license="MIT"
depends="gnupg git"
makedepends="go ncurses"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz"
-options="chmod-clean"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gopasspw/gopass/archive/v$pkgver.tar.gz
+ enable-cgo.patch"
+options="chmod-clean net"
subpackages="
$pkgname-bash-completion
$pkgname-zsh-completion
@@ -19,21 +20,26 @@ subpackages="
$pkgname-doc
"
-check() {
- # This fails if user already has a ~/.password-store
- GOPATH="$srcdir" make test-integration
-}
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- GOPATH="$srcdir" make build BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+ make build BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+}
+
+check() {
+ # This fails if user already has a ~/.password-store
+ make test-integration
}
package() {
- GOPATH="$srcdir" make install DESTDIR="$pkgdir" PREFIX="/usr" BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
+ make install DESTDIR="$pkgdir" PREFIX="/usr" BUILDFLAGS="\$(BUILDFLAGS_NOPIE) $GOFLAGS"
install -Dm0644 "$builddir"/fish.completion \
- "$pkgdir"/usr/share/fish/completions/gopass.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/gopass.fish
}
sha512sums="
-d3b6357701b70c352508f454a401b6bd4e8e184234186242b21257d0a40de81d91d74ade6f5fd972b906de9be24d57095846037de75c1ae740b447e4bdc9898f gopass-1.13.1.tar.gz
+09359ee0006a4e0cd7feb45b67e77192208dbabbd590f4c67de222159dad1ea44a73381e2edd1928d0205d771b3116a65652e802cf61890fe58955601e76a5e0 gopass-1.15.12.tar.gz
+0866b5378abc1c621d188c5dd6afe25841dd1459f176543f93d319c0e041e701a80e0d51c1977d2e6ed892b38730248217b2c9c7c53f3dddaa155f5c2a311456 enable-cgo.patch
"