aboutsummaryrefslogtreecommitdiffstats
path: root/community/gotop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gotop/APKBUILD')
-rw-r--r--community/gotop/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/gotop/APKBUILD b/community/gotop/APKBUILD
index 7fe0132eb6c..59956e0a7f1 100644
--- a/community/gotop/APKBUILD
+++ b/community/gotop/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=gotop
-pkgver=4.1.1
-pkgrel=1
+pkgver=4.2.0
+pkgrel=13
pkgdesc="Terminal based graphical activity monitor"
url="https://github.com/xxxserxxx/gotop"
arch="all"
@@ -14,9 +14,13 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/xxxserxxx/gotop/archive/v$pk
0001-logging-add-support-for-riscv64.patch
"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
mkdir bin
- GOPATH="$srcdir" go build -v -o bin/ ./...
+ go build -v -o bin/ ./...
}
package() {
@@ -25,6 +29,6 @@ package() {
}
sha512sums="
-6b1751c4625907201a07ab3b312ddadc9e0b1c86a4d51844e26b75f64cd4b2defb98419f77c0028ef45de223af88eb9c65d7b499da3106ba8096203cd31a7863 gotop-4.1.1.tar.gz
-30dc60eec54352a02c833ee6d71505af2095065ed9a9ce9e587b11ec87cb574c52b1a6aa7e09b486a62d108446b7e6ac7e4c1fa81fcf3097a1fd7aea77e5d12d 0001-logging-add-support-for-riscv64.patch
+32973f4e6677f885062051940119fb77f95d0bbfe653dcfce9c0a67a986f0cafc51916fe625038e31d7fc6698d170821fc56c4445b4c8ec666d180b604d5c5ac gotop-4.2.0.tar.gz
+53c085dd0e495116e5f8cda6796113630bf27935007098006d164773912f611d2cadfae80aaa12c8796becb77a17ddc5905d26d31b078db9249f5668de93da34 0001-logging-add-support-for-riscv64.patch
"