aboutsummaryrefslogtreecommitdiffstats
path: root/community/gotop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gotop/APKBUILD')
-rw-r--r--community/gotop/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/community/gotop/APKBUILD b/community/gotop/APKBUILD
index 8e7aa98b1f0..59956e0a7f1 100644
--- a/community/gotop/APKBUILD
+++ b/community/gotop/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=gotop
-pkgver=4.1.1
-pkgrel=0
+pkgver=4.2.0
+pkgrel=13
pkgdesc="Terminal based graphical activity monitor"
url="https://github.com/xxxserxxx/gotop"
arch="all"
@@ -10,11 +10,17 @@ license="AGPL-3.0-or-later"
options="!check chmod-clean net" # No test suite
depends="procps" # Remove once #20 on xxxserxxx/gotop is fixed
makedepends="git go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/xxxserxxx/gotop/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xxxserxxx/gotop/archive/v$pkgver.tar.gz
+ 0001-logging-add-support-for-riscv64.patch
+ "
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
mkdir bin
- GOPATH="$srcdir" go build -v -o bin/ ./...
+ go build -v -o bin/ ./...
}
package() {
@@ -22,4 +28,7 @@ package() {
install -m755 ./bin/* "$pkgdir"/usr/bin/
}
-sha512sums="6b1751c4625907201a07ab3b312ddadc9e0b1c86a4d51844e26b75f64cd4b2defb98419f77c0028ef45de223af88eb9c65d7b499da3106ba8096203cd31a7863 gotop-4.1.1.tar.gz"
+sha512sums="
+32973f4e6677f885062051940119fb77f95d0bbfe653dcfce9c0a67a986f0cafc51916fe625038e31d7fc6698d170821fc56c4445b4c8ec666d180b604d5c5ac gotop-4.2.0.tar.gz
+53c085dd0e495116e5f8cda6796113630bf27935007098006d164773912f611d2cadfae80aaa12c8796becb77a17ddc5905d26d31b078db9249f5668de93da34 0001-logging-add-support-for-riscv64.patch
+"