aboutsummaryrefslogtreecommitdiffstats
path: root/community/gotop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gotop/APKBUILD')
-rw-r--r--community/gotop/APKBUILD36
1 files changed, 16 insertions, 20 deletions
diff --git a/community/gotop/APKBUILD b/community/gotop/APKBUILD
index 06bcc893b95..59956e0a7f1 100644
--- a/community/gotop/APKBUILD
+++ b/community/gotop/APKBUILD
@@ -1,28 +1,26 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=gotop
-pkgver=4.0.1
-pkgrel=0
+pkgver=4.2.0
+pkgrel=13
pkgdesc="Terminal based graphical activity monitor"
url="https://github.com/xxxserxxx/gotop"
-arch="all !mips64"
+arch="all"
license="AGPL-3.0-or-later"
-options="!check" # No test suite
+options="!check chmod-clean net" # No test suite
depends="procps" # Remove once #20 on xxxserxxx/gotop is fixed
makedepends="git go"
-options="net"
-source="$pkgname-$pkgver.tar.gz::https://github.com/xxxserxxx/gotop/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/xxxserxxx/gotop"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xxxserxxx/gotop/archive/v$pkgver.tar.gz
+ 0001-logging-add-support-for-riscv64.patch
+ "
-prepare() {
- default_prepare
- mkdir -p "$srcdir"/src/github.com/xxxserxxx
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
-}
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
mkdir bin
- GOPATH="$srcdir" go build -v -o bin/ ./...
+ go build -v -o bin/ ./...
}
package() {
@@ -30,9 +28,7 @@ package() {
install -m755 ./bin/* "$pkgdir"/usr/bin/
}
-cleanup_srcdir() {
- [ -d src ] && chmod -R +w src
- default_cleanup_srcdir
-}
-
-sha512sums="3ff8b5e97c39fb58d32c8b2c8f8bdbe70e2c320b702e47b9b04e49ea3b69ff31004800fd431ffb3cd9f705443c47d62100b82c483e8c5b9977cfe1e504f018bc gotop-4.0.1.tar.gz"
+sha512sums="
+32973f4e6677f885062051940119fb77f95d0bbfe653dcfce9c0a67a986f0cafc51916fe625038e31d7fc6698d170821fc56c4445b4c8ec666d180b604d5c5ac gotop-4.2.0.tar.gz
+53c085dd0e495116e5f8cda6796113630bf27935007098006d164773912f611d2cadfae80aaa12c8796becb77a17ddc5905d26d31b078db9249f5668de93da34 0001-logging-add-support-for-riscv64.patch
+"