aboutsummaryrefslogtreecommitdiffstats
path: root/community/gotop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gotop/APKBUILD')
-rw-r--r--community/gotop/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/gotop/APKBUILD b/community/gotop/APKBUILD
index dedffe204e5..59956e0a7f1 100644
--- a/community/gotop/APKBUILD
+++ b/community/gotop/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=gotop
-pkgver=4.1.2
-pkgrel=1
+pkgver=4.2.0
+pkgrel=13
pkgdesc="Terminal based graphical activity monitor"
url="https://github.com/xxxserxxx/gotop"
arch="all"
@@ -14,9 +14,13 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/xxxserxxx/gotop/archive/v$pk
0001-logging-add-support-for-riscv64.patch
"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
mkdir bin
- GOPATH="$srcdir" go build -v -o bin/ ./...
+ go build -v -o bin/ ./...
}
package() {
@@ -25,6 +29,6 @@ package() {
}
sha512sums="
-8b280bddd782fa8cd1e454d83b3b3a7abe1e7d07af1c5587f1bfc317dfff1aa3fb2682317e81ab2c63f0e064d379a0f50d9af0244215702b8c4fcb5fb9495693 gotop-4.1.2.tar.gz
+32973f4e6677f885062051940119fb77f95d0bbfe653dcfce9c0a67a986f0cafc51916fe625038e31d7fc6698d170821fc56c4445b4c8ec666d180b604d5c5ac gotop-4.2.0.tar.gz
53c085dd0e495116e5f8cda6796113630bf27935007098006d164773912f611d2cadfae80aaa12c8796becb77a17ddc5905d26d31b078db9249f5668de93da34 0001-logging-add-support-for-riscv64.patch
"