aboutsummaryrefslogtreecommitdiffstats
path: root/community/gource/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gource/APKBUILD')
-rw-r--r--community/gource/APKBUILD45
1 files changed, 32 insertions, 13 deletions
diff --git a/community/gource/APKBUILD b/community/gource/APKBUILD
index a6aa0e663a0..6d25e1912bb 100644
--- a/community/gource/APKBUILD
+++ b/community/gource/APKBUILD
@@ -1,32 +1,51 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gource
-pkgver=0.51
-pkgrel=4
+pkgver=0.54
+pkgrel=1
pkgdesc="Software version control visualization"
url="https://gource.io/"
arch="all !s390x"
license="GPL-3.0"
-makedepends="ftgl-dev sdl2-dev sdl2_image-dev pcre-dev glew-dev libpng-dev
- libjpeg-turbo-dev glu-dev boost-dev glm-dev"
+makedepends="
+ boost-dev
+ ftgl-dev
+ glew-dev
+ glm-dev
+ glu-dev
+ libjpeg-turbo-dev
+ libpng-dev
+ pcre2-dev
+ sdl2-dev
+ sdl2_image-dev
+ tinyxml-dev
+ "
subpackages="$pkgname-doc"
-source="https://github.com/acaudwell/Gource/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://github.com/acaudwell/Gource/releases/download/gource-$pkgver/gource-$pkgver.tar.gz
+ disable-failing-test.patch
+ "
build() {
- cd "$builddir"
- ./configure --prefix=/usr
+ ./configure \
+ --host=$CHOST \
+ --build=$CBUILD \
+ --prefix=/usr \
+ --with-tinyxml
make
}
check() {
- cd "$builddir"
- make check
+ make check || {
+ cat ./test-suite.log
+ return 1
+ }
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="f29326ffb2aa6f645fb941e08e41f0cbf8dd894d5a4d607b782caeb12a24e6446198027060b880e0ad14a36efbed19023620dd8c890cfc0c027fc90ac2d5be24 gource-0.51.tar.gz"
+sha512sums="
+a9fd2ff7c51931a543d4ab6dc85dd4b2c187ecca1be630006bb60ac2507180ccf40561e37f50493e052c839d9f5f896ae8f113fb65844c2fa9bde33fcd6b53e8 gource-0.54.tar.gz
+65a66b8b4c6facd859cd10f9a7030d2a4803ffb4056cbe48577c976cb6943c5dbd0c2c932808e25323300cc99ed232b5f31c5599ccd4aabcba814dfa42734b88 disable-failing-test.patch
+"