aboutsummaryrefslogtreecommitdiffstats
path: root/community/govc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/govc/APKBUILD')
-rw-r--r--community/govc/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/govc/APKBUILD b/community/govc/APKBUILD
index 2f96e7e5679..4441d44d6aa 100644
--- a/community/govc/APKBUILD
+++ b/community/govc/APKBUILD
@@ -1,20 +1,22 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=govc
-pkgver=0.29.0
-pkgrel=2
+pkgver=0.36.3
+pkgrel=1
pkgdesc="vSphere CLI built on top of govmomi"
-url="https://github.com/vmware/govmomi/tree/master/govc"
+url="https://github.com/vmware/govmomi/blob/main/govc/README.md"
arch="all"
license="Apache-2.0"
makedepends="go bash coreutils"
source="https://github.com/vmware/govmomi/archive/v$pkgver/govc-$pkgver.tar.gz"
builddir="$srcdir/govmomi-$pkgver/govc"
-options="!check" # no tests provided
+# !check: no tests provided
+# net: fetch dependencies
+options="!check net"
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -o "$builddir"/govc .
@@ -25,5 +27,5 @@ package() {
}
sha512sums="
-f43cdb8333775689ede39bc2f488433de1a8c6be9cffd534f50023557f5fde3bddc6f2ead88d9f23d0de3a7ed16191bc4daa1e7f31dceb80055feb202c94ab7e govc-0.29.0.tar.gz
+742c37be81fde603e78d862c2401d6be8efaaaa8929193379ad13651f9ba0b0792571742a2c4bed28d19af9056f3e45c67ad22cc6913c823ee78e807afd874e2 govc-0.36.3.tar.gz
"