aboutsummaryrefslogtreecommitdiffstats
path: root/community/govc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/govc/APKBUILD')
-rw-r--r--community/govc/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/govc/APKBUILD b/community/govc/APKBUILD
index 112e128a244..4441d44d6aa 100644
--- a/community/govc/APKBUILD
+++ b/community/govc/APKBUILD
@@ -1,25 +1,31 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=govc
-pkgver=0.27.2
-pkgrel=0
+pkgver=0.36.3
+pkgrel=1
pkgdesc="vSphere CLI built on top of govmomi"
-url="https://github.com/vmware/govmomi/tree/master/govc"
+url="https://github.com/vmware/govmomi/blob/main/govc/README.md"
arch="all"
license="Apache-2.0"
makedepends="go bash coreutils"
source="https://github.com/vmware/govmomi/archive/v$pkgver/govc-$pkgver.tar.gz"
builddir="$srcdir/govmomi-$pkgver/govc"
-options="!check" # no tests provided
+# !check: no tests provided
+# net: fetch dependencies
+options="!check net"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -o "$builddir/govc" .
+ go build -o "$builddir"/govc .
}
package() {
- install -Dm755 "$builddir/govc" "$pkgdir/usr/bin/govc"
+ install -Dm755 "$builddir"/govc "$pkgdir"/usr/bin/govc
}
sha512sums="
-90796494913772b275a52d5cc3bc482809dc23ff3689b3a3aedec77cffb5dc9d4aed95822ff62c659b787818729f7ce2135429f6dbf79b0a783f2a81497beff3 govc-0.27.2.tar.gz
+742c37be81fde603e78d862c2401d6be8efaaaa8929193379ad13651f9ba0b0792571742a2c4bed28d19af9056f3e45c67ad22cc6913c823ee78e807afd874e2 govc-0.36.3.tar.gz
"