aboutsummaryrefslogtreecommitdiffstats
path: root/community/govendor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/govendor/APKBUILD')
-rw-r--r--community/govendor/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/community/govendor/APKBUILD b/community/govendor/APKBUILD
deleted file mode 100644
index 9d83b7ec8f6..00000000000
--- a/community/govendor/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
-pkgname=govendor
-pkgver=1.0.9
-pkgrel=6
-pkgdesc="Go vendor tool that works with the standard vendor file"
-url="https://github.com/kardianos/govendor"
-# riscv64 is broken
-arch="all !riscv64"
-license="BSD-3-Clause"
-makedepends="go"
-source="govendor-$pkgver.tar.gz::https://github.com/kardianos/govendor/archive/v$pkgver.tar.gz"
-builddir="$srcdir/github.com/kardianos/$pkgname"
-
-
-prepare() {
- mkdir -p ${builddir%/*}
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
- default_prepare
-}
-
-build() {
- export GO111MODULE=off
- export GOPATH="$startdir"
- go build -v
-}
-
-package() {
- install -Dm755 "$builddir"/govendor "$pkgdir"/usr/bin/govendor
-}
-
-sha512sums="3ea102e4f0fb8d6619dae3ba7a8022c81fc5711fad8e874c1cb1bfc0c830fa50a057035fb28a060c3b0fb2dd10b65881bf91e5260c48827819610bf483d9884e govendor-1.0.9.tar.gz"