aboutsummaryrefslogtreecommitdiffstats
path: root/community/gpaste/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gpaste/APKBUILD')
-rw-r--r--community/gpaste/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/gpaste/APKBUILD b/community/gpaste/APKBUILD
index 0c155ac6afb..0f5b193fda3 100644
--- a/community/gpaste/APKBUILD
+++ b/community/gpaste/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gpaste
-pkgver=42.1
-pkgrel=0
+pkgver=44.1
+pkgrel=1
pkgdesc="Clipboard managment system"
url="https://github.com/Keruspe/GPaste"
-arch="all !s390x !riscv64" # limited by gnome-control-center
+arch="all !armhf !s390x !riscv64" # limited by gnome-control-center
license="BSD-2-Clause"
makedepends="
appstream-glib-dev
dbus-dev
+ desktop-file-utils
+ gcr4-dev
gjs-dev
gnome-control-center-dev
gtk+3.0-dev
@@ -26,20 +28,23 @@ subpackages="
$pkgname-bash-completion:bashcomp
$pkgname-zsh-completion:zshcomp
"
-source="gpaste-$pkgver.tar.gz::https://github.com/Keruspe/GPaste/archive/v$pkgver.tar.gz"
+source="gpaste-$pkgver.tar.gz::https://github.com/Keruspe/GPaste/archive/v$pkgver.tar.gz
+ mutter-clutter-13.patch
+ "
builddir="$srcdir/GPaste-$pkgver"
build() {
abuild-meson \
+ -Db_lto=true \
-Dsystemd=false \
-Dintrospection=true \
-Dvapi=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -49,12 +54,12 @@ package() {
_gnome() {
install_if="$pkgname=$pkgver-r$pkgrel gnome-shell gnome-control-center"
depends="gnome-control-center"
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/gnome-shell \
- "$pkgdir"/usr/share/gnome-control-center \
- "$subpkgdir"/usr/share
+
+ amove usr/share/gnome-shell
+ amove usr/share/gnome-control-center
}
sha512sums="
-e3f51da55b53e03758450bee967a9f23908c06db71cf687f6de000efb4715263e25020028d488797d8e1f75154f2f00c59b3a427f1aeca5d0132ac927060047e gpaste-42.1.tar.gz
+50cf65b1f89415d6bef8e2c7bcde5d775b2b3c05e9e296df23a2913efd13fa678adb543393d536ee9e7682dc604498f943babc840d821a6c8fbebbdcc6c2d39a gpaste-44.1.tar.gz
+fb1406a2794500a48250311ad8a2ceb9ff54c10949c6b1f52cc043ba424142ec280fb01ffc6fda7ef503d69e2825d9a816babcdd19aa3ef2f3fe5bd2063f7b1c mutter-clutter-13.patch
"