aboutsummaryrefslogtreecommitdiffstats
path: root/community/gpodder-adaptive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gpodder-adaptive/APKBUILD')
-rw-r--r--community/gpodder-adaptive/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/community/gpodder-adaptive/APKBUILD b/community/gpodder-adaptive/APKBUILD
index 6115f42b9f8..bd176accd2a 100644
--- a/community/gpodder-adaptive/APKBUILD
+++ b/community/gpodder-adaptive/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
# Contributor: Johannes Marbach <n0-0ne+gitlab@mailbox.org>
pkgname=gpodder-adaptive
-pkgver=3.10.21
+pkgver=3.11.4
_plusver=1
-pkgrel=1
+pkgrel=0
pkgdesc="Podcast aggregator (adaptive version)"
url="https://github.com/gpodder/gpodder/tree/adaptive"
-arch="all !s390x !mips !mips64 !riscv64" # blocked by adwaita-icon-theme
+arch="all !s390x !riscv64" # blocked by adwaita-icon-theme
license="GPL-3.0-or-later"
depends="
adwaita-icon-theme
@@ -23,11 +23,8 @@ depends="
"
makedepends="py3-setuptools intltool help2man"
checkdepends="py3-pytest py3-pytest-httpserver py3-pytest-cov py3-minimock desktop-file-utils"
-subpackages="$pkgname-doc $pkgname-lang"
-source="gpodder-adaptive-$pkgver+$_plusver.tar.gz::https://github.com/gpodder/gpodder/archive/refs/tags/adaptive/$pkgver+$_plusver.tar.gz
- 0001-gtkui-fix-loading-of-cached-thumbnails.patch
- 0002-gtkui-properly-scale-cover-pill-on-hires-displays.patch
- "
+subpackages="$pkgname-doc $pkgname-lang $pkgname-pyc"
+source="gpodder-adaptive-$pkgver+$_plusver.tar.gz::https://github.com/gpodder/gpodder/archive/refs/tags/adaptive/$pkgver+$_plusver.tar.gz"
builddir="$srcdir/gpodder-adaptive-$pkgver-$_plusver"
check() {
@@ -36,10 +33,11 @@ check() {
package() {
make install PREFIX=/usr DESTDIR=$pkgdir
+
+ touch no-update-check
+ install -Dm644 no-update-check -t "$pkgdir"/usr/share/gpodder
}
sha512sums="
-296ce9fcc65b11b93e9501f99ffc916632ea142c06fdba3cda87def177dc61ddf5901fef574eed0b8cda65c5c6f530a57707a2c7c2f2d9bf67c79d167be354b9 gpodder-adaptive-3.10.21+1.tar.gz
-bad2742d3522cd3a9fdcc7ffe85df04620b865c4bb3a88a1149b3b07e2d1289751b10c7b53d3f2fc35f9c71c6eb92bc8306304ef7c74a230afb9dcf131ac637f 0001-gtkui-fix-loading-of-cached-thumbnails.patch
-f939e46b627abfc5eec059879d4042cee0a9da146f265127f6634f24eb7da5588642323e79c264e4cee4acf0c9953a0bd8578eb56271327e04a3a46f9e4e297a 0002-gtkui-properly-scale-cover-pill-on-hires-displays.patch
+c5920a74abd8deecdbf0a643cdf9ff818e3f5c220195d6a658627ff1856fc4a7c7bcac98fe4dd2efa576388219d0dd3a37bf1156f33d39a13eab96bccf321dee gpodder-adaptive-3.11.4+1.tar.gz
"