aboutsummaryrefslogtreecommitdiffstats
path: root/community/gpodder/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gpodder/APKBUILD')
-rw-r--r--community/gpodder/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/gpodder/APKBUILD b/community/gpodder/APKBUILD
new file mode 100644
index 00000000000..145e2e22792
--- /dev/null
+++ b/community/gpodder/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
+pkgname=gpodder
+pkgver=3.11.4
+pkgrel=1
+pkgdesc="Podcast aggregator"
+url="https://gpodder.org"
+arch="noarch !s390x !riscv64" # blocked by adwaita-icon-theme
+license="GPL-3.0-or-later"
+depends="
+ adwaita-icon-theme
+ py3-cairo
+ py3-dbus
+ py3-gobject3
+ py3-html5lib
+ py3-mygpoclient
+ py3-podcastparser
+ py3-requests
+ python3
+ xdg-utils
+"
+makedepends="py3-setuptools intltool help2man"
+checkdepends="py3-pytest py3-pytest-httpserver py3-pytest-cov py3-minimock desktop-file-utils"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gpodder/gpodder/archive/refs/tags/$pkgver.tar.gz"
+
+check() {
+ make unittest
+}
+
+package() {
+ make install PREFIX=/usr DESTDIR=$pkgdir
+
+ touch no-update-check
+ install -Dm644 no-update-check -t "$pkgdir"/usr/share/gpodder
+}
+
+sha512sums="
+f60e2e04abec7d9713d169f9eccb431325bcfe40303e14d0cb42c3b5b4696d7435b86eb1c69b430ef99f81a6b71f89dffafec84d1f1c51118af59e57dcfa0d2d gpodder-3.11.4.tar.gz
+"