aboutsummaryrefslogtreecommitdiffstats
path: root/community/granatier/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/granatier/APKBUILD')
-rw-r--r--community/granatier/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/granatier/APKBUILD b/community/granatier/APKBUILD
index 7a7436c087a..23db4fc72a7 100644
--- a/community/granatier/APKBUILD
+++ b/community/granatier/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=granatier
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/org.kde.granatier"
pkgdesc="A clone of the classic Bomberman game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -23,23 +25,24 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/granatier-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/granatier.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/granatier-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +50,5 @@ package() {
}
sha512sums="
-03749337ce270b1513053ad474b624f75a87cd460be6743d33f2e0afb8691af9887edf11e938734e06b59e77ae3a759c622425fe1c45c817b4c59ae2548c0161 granatier-21.08.2.tar.xz
+dd3c56807141daee192919771aa57ef49042eb4a8d8f4b692116f72e03bf0b68aa59ad5d816b1ab3569705db797dd7a3ef3e0992b4c4685763337250b986579d granatier-24.02.2.tar.xz
"