aboutsummaryrefslogtreecommitdiffstats
path: root/community/granatier/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/granatier/APKBUILD')
-rw-r--r--community/granatier/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/granatier/APKBUILD b/community/granatier/APKBUILD
index 844d48f1b90..23db4fc72a7 100644
--- a/community/granatier/APKBUILD
+++ b/community/granatier/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=granatier
-pkgver=22.04.0
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/org.kde.granatier"
pkgdesc="A clone of the classic Bomberman game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -23,12 +25,13 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/granatier-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/granatier.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/granatier-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -39,8 +42,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -48,5 +50,5 @@ package() {
}
sha512sums="
-62f49f0b73dbea4dca8cadb01fce8887155fc0b1c1a9268d9344f319cb46bc795845a566a85c1fc4611c74572d5f1c23ae6a3686f57d0c8ddbaa74125de64e4f granatier-22.04.0.tar.xz
+dd3c56807141daee192919771aa57ef49042eb4a8d8f4b692116f72e03bf0b68aa59ad5d816b1ab3569705db797dd7a3ef3e0992b4c4685763337250b986579d granatier-24.02.2.tar.xz
"