aboutsummaryrefslogtreecommitdiffstats
path: root/community/grantlee-editor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/grantlee-editor/APKBUILD')
-rw-r--r--community/grantlee-editor/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/community/grantlee-editor/APKBUILD b/community/grantlee-editor/APKBUILD
index 96fba8931a7..5fba3965fee 100644
--- a/community/grantlee-editor/APKBUILD
+++ b/community/grantlee-editor/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=grantlee-editor
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
pkgdesc="Utilities and tools to manage themes in KDE PIM applications "
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -20,30 +23,33 @@ makedepends="
kimap-dev
knewstuff-dev
kpimtextedit-dev
+ ktextaddons-dev
ktexteditor-dev
+ ktextwidgets-dev
kxmlgui-dev
libkleo-dev
messagelib-dev
pimcommon-dev
qgpgme
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
syntax-highlighting-dev
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/grantlee-editor-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/grantlee-editor.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/grantlee-editor-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -51,5 +57,5 @@ package() {
}
sha512sums="
-4e1b0a74b4115f3f4bbebdae82dedb21ac8093f7d327c77d45b3b8794d74a17562f288f022cbb11bb790a3acf4e700f9f30d7f637813bc56ac02353c0755b20b grantlee-editor-21.04.3.tar.xz
+06cf06beefd5bc79c977793a33ac168a39bcfe58d55b7917dc05097c35a8fb7713444c53cca3aa9104253937ebc2329562bd55f48c2416533693af908279097e grantlee-editor-24.02.1.tar.xz
"