aboutsummaryrefslogtreecommitdiffstats
path: root/community/grantlee-editor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/grantlee-editor/APKBUILD')
-rw-r--r--community/grantlee-editor/APKBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/community/grantlee-editor/APKBUILD b/community/grantlee-editor/APKBUILD
new file mode 100644
index 00000000000..4db92f0deec
--- /dev/null
+++ b/community/grantlee-editor/APKBUILD
@@ -0,0 +1,61 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
+pkgname=grantlee-editor
+pkgver=24.02.2
+pkgrel=0
+pkgdesc="Utilities and tools to manage themes in KDE PIM applications "
+# armhf blocked by extra-cmake-modules
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
+url="https://kontact.kde.org/"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="
+ akonadi-mime-dev
+ extra-cmake-modules
+ grantleetheme-dev
+ karchive-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kimap-dev
+ knewstuff-dev
+ kpimtextedit-dev
+ ktextaddons-dev
+ ktexteditor-dev
+ ktextwidgets-dev
+ kxmlgui-dev
+ libkleo-dev
+ messagelib-dev
+ pimcommon-dev
+ qgpgme
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
+ syntax-highlighting-dev
+ "
+subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/grantlee-editor.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/grantlee-editor-$pkgver.tar.xz"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+28d91691f5116c4a0f52f207a3c5199a6402b2d623024e0b30b2e93bc0d21fc171bd7a5b7faa99471d851760839494efd0abbfcb69ec47acdaaf4a6f2c0a1f29 grantlee-editor-24.02.2.tar.xz
+"