aboutsummaryrefslogtreecommitdiffstats
path: root/community/grantlee-editor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/grantlee-editor/APKBUILD')
-rw-r--r--community/grantlee-editor/APKBUILD54
1 files changed, 42 insertions, 12 deletions
diff --git a/community/grantlee-editor/APKBUILD b/community/grantlee-editor/APKBUILD
index 3f81f42fd50..4db92f0deec 100644
--- a/community/grantlee-editor/APKBUILD
+++ b/community/grantlee-editor/APKBUILD
@@ -1,31 +1,61 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=grantlee-editor
-pkgver=21.04.0
+pkgver=24.02.2
pkgrel=0
-arch="all !ppc64le !s390x !armhf !mips !mips64" # Limited by qt5-qtwebengine
-url="https://kontact.kde.org/"
pkgdesc="Utilities and tools to manage themes in KDE PIM applications "
+# armhf blocked by extra-cmake-modules
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
+url="https://kontact.kde.org/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtwebengine-dev kcrash-dev kdbusaddons-dev kdoctools-dev kxmlgui-dev ktexteditor-dev knewstuff-dev karchive-dev pimcommon-dev messagelib-dev grantleetheme-dev akonadi-mime-dev libkleo-dev kimap-dev kpimtextedit-dev syntax-highlighting-dev qgpgme"
-source="https://download.kde.org/stable/release-service/$pkgver/src/grantlee-editor-$pkgver.tar.xz"
+makedepends="
+ akonadi-mime-dev
+ extra-cmake-modules
+ grantleetheme-dev
+ karchive-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kimap-dev
+ knewstuff-dev
+ kpimtextedit-dev
+ ktextaddons-dev
+ ktexteditor-dev
+ ktextwidgets-dev
+ kxmlgui-dev
+ libkleo-dev
+ messagelib-dev
+ pimcommon-dev
+ qgpgme
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
+ syntax-highlighting-dev
+ "
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/grantlee-editor.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/grantlee-editor-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="670cb5f3287881dcfdcc7df8898b2b42b63568592f253bf33edb5f2f1905aa8c97e001909128f6292f383e8fc9ca173511aa2bfec10651becbd7137f4ebfcb13 grantlee-editor-21.04.0.tar.xz"
+sha512sums="
+28d91691f5116c4a0f52f207a3c5199a6402b2d623024e0b30b2e93bc0d21fc171bd7a5b7faa99471d851760839494efd0abbfcb69ec47acdaaf4a6f2c0a1f29 grantlee-editor-24.02.2.tar.xz
+"