aboutsummaryrefslogtreecommitdiffstats
path: root/community/graphicsmagick/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/graphicsmagick/APKBUILD')
-rw-r--r--community/graphicsmagick/APKBUILD48
1 files changed, 35 insertions, 13 deletions
diff --git a/community/graphicsmagick/APKBUILD b/community/graphicsmagick/APKBUILD
index 90bb1c13bb3..701ce6a3f61 100644
--- a/community/graphicsmagick/APKBUILD
+++ b/community/graphicsmagick/APKBUILD
@@ -1,20 +1,31 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=graphicsmagick
-pkgver=1.3.37
+pkgver=1.3.43
pkgrel=0
pkgdesc="Image processing system"
url="http://www.graphicsmagick.org/"
arch="all"
license="MIT"
-makedepends="libpng-dev tiff-dev libxml2-dev libwmf-dev freetype-dev libtool libltdl
- libwebp-dev"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="
+ freetype-dev
+ libheif-dev
+ libltdl
+ libpng-dev
+ libtool
+ libwebp-dev
+ libwmf-dev
+ libxml2-dev
+ tiff-dev
+ "
+subpackages="$pkgname-dev $pkgname-c++:cpp $pkgname-doc"
source="https://downloads.sourceforge.net/graphicsmagick/graphicsmagick/$pkgver/GraphicsMagick-$pkgver.tar.xz"
-options="libtool !check"
+options="libtool"
builddir="$srcdir"/GraphicsMagick-$pkgver
# secfixes:
+# 1.3.38-r0:
+# - CVE-2022-1270
# 1.3.35-r2:
# - CVE-2020-12672
# 1.3.35-r0:
@@ -119,22 +130,33 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --enable-shared \
- --disable-static \
--disable-openmp \
- --with-modules \
- --with-threads \
+ --disable-static \
+ --enable-shared \
--with-gs-font-dir=/usr/share/fonts/Type1 \
+ --with-modules \
+ --with-perl \
--with-quantum-depth=16 \
- --with-webp \
- --with-ttf
+ --with-threads \
+ --with-ttf \
+ --with-webp
make
}
+check() {
+ make check
+}
+
package() {
- make -j1 DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make install
+}
+
+cpp() {
+ pkgdesc="$pkgdesc (c++ module)"
+
+ amove usr/lib/libGraphicsMagick++.*
}
sha512sums="
-971e05480a65eb99ff3c0d874675bcbffc24eafec1cacd03f5ef410ae014f82329f3590393100927f753feb183be1105fe0cfc5b0f775a30b0e6dc0c6b8a77af GraphicsMagick-1.3.37.tar.xz
+15b4d90119f25fd45f16d50218d51d543841dd3cdaf0c585bce2c18592106bc41573ed1011d7176ff5882fa0cded8f46bfd1e639c26063571109911e22098757 GraphicsMagick-1.3.43.tar.xz
"