aboutsummaryrefslogtreecommitdiffstats
path: root/community/grpc/makefile-use-system-abseil.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/grpc/makefile-use-system-abseil.patch')
-rw-r--r--community/grpc/makefile-use-system-abseil.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/grpc/makefile-use-system-abseil.patch b/community/grpc/makefile-use-system-abseil.patch
new file mode 100644
index 00000000000..ac4f9fc0510
--- /dev/null
+++ b/community/grpc/makefile-use-system-abseil.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -575,8 +575,8 @@
+
+ # Setup abseil dependency
+
+-GRPC_ABSEIL_DEP = $(LIBDIR)/$(CONFIG)/libgrpc_abseil.a
+-GRPC_ABSEIL_MERGE_LIBS = $(LIBDIR)/$(CONFIG)/libgrpc_abseil.a
++GRPC_ABSEIL_DEP = -labsl_base -labsl_int128 -labsl_strings -labsl_time -labsl_bad_optional_access -labsl_throw_delegate -labsl_str_format_internal
++GRPC_ABSEIL_MERGE_LIBS = -labsl_base -labsl_int128 -labsl_strings -labsl_time -labsl_bad_optional_access -labsl_throw_delegate -labsl_str_format_internal
+
+ # Setup re2 dependency
+
+@@ -2809,7 +2809,7 @@
+ third_party/abseil-cpp/absl/types/bad_variant_access.cc \
+
+
+-LIBGRPC_ABSEIL_OBJS = $(addprefix $(OBJDIR)/$(CONFIG)/, $(addsuffix .o, $(basename $(LIBGRPC_ABSEIL_SRC))))
++LIBGRPC_ABSEIL_OBJS =
+
+ $(LIBGRPC_ABSEIL_OBJS): CPPFLAGS += -g -Ithird_party/abseil-cpp
+