aboutsummaryrefslogtreecommitdiffstats
path: root/community/gsa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gsa/APKBUILD')
-rw-r--r--community/gsa/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/gsa/APKBUILD b/community/gsa/APKBUILD
index 790b6b646fa..a1b8ab971fc 100644
--- a/community/gsa/APKBUILD
+++ b/community/gsa/APKBUILD
@@ -1,17 +1,26 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gsa
-pkgver=21.4.4
+pkgver=23.0.0
pkgrel=0
pkgdesc="Greenbone Security Assistant - The web frontend for the Greenbone Vulnerability Management (GVM) framework "
url="https://github.com/greenbone/gsa"
-arch="noarch !riscv64" # limited by nodejs
-license="APL-3.0"
-makedepends="yarn nodejs"
+# riscv64: NonErrorEmittedError: (Emitted value instead of an instance of Error) [object Object]
+arch="noarch !riscv64"
+license="AGPL-3.0-or-later"
+options="net"
+makedepends="yarn nodejs-current"
source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/gsa/archive/refs/tags/v$pkgver.tar.gz
- remove-husky-git-hook.patch"
+ remove-husky-git-hook.patch
+ "
+
+prepare() {
+ default_prepare
+ rm -rf build
+}
build() {
+ export NODE_OPTIONS="--openssl-legacy-provider"
yarn
yarn build
}
@@ -26,6 +35,6 @@ package() {
}
sha512sums="
-5a7b45132a049adf608ccd8988d69a415290cc57d6e7537835a78e19aafb5dfdf204197576f69277726587efaccce189c1ccab55c43e5a0a7855c538b3bc4b67 gsa-21.4.4.tar.gz
-72e5491a7df8059d56903391803e0064c391eb4023dff25b575e5ca66408d91fd639462b4d6ccfff4b49b21b07484670c34b802bffa7dedbb5d2c0230cd5234c remove-husky-git-hook.patch
+d2dfe12777a8b7610ebc1e7eceb079d38ae1f83085c5a411c115950e55254c82151f77ce16d12342d40b457999f50348a48e66f236a83d145697f68ef9caf993 gsa-23.0.0.tar.gz
+887dac02a4509f71ccd757234f3c80505cd2f094c2ac1b19c4666619c9a80442dda098d69e830986c7c6f4931687a5d60e700f78c52985cca0f6ff869235d6c0 remove-husky-git-hook.patch
"