aboutsummaryrefslogtreecommitdiffstats
path: root/community/gspell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gspell/APKBUILD')
-rw-r--r--community/gspell/APKBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/community/gspell/APKBUILD b/community/gspell/APKBUILD
index e565d9cae72..51972898228 100644
--- a/community/gspell/APKBUILD
+++ b/community/gspell/APKBUILD
@@ -1,26 +1,26 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gspell
-pkgver=1.9.1
-pkgrel=1
+pkgver=1.12.2
+pkgrel=2
pkgdesc="Flexible API to add spell checking to a GTK+ application"
options="!check" # Test fails because of missing machine-id
url="https://wiki.gnome.org/Projects/gspell"
arch="all"
license="LGPL-2.1-or-later"
depends="iso-codes"
-makedepends="glib-dev vala iso-codes-dev gtk+3.0-dev enchant2-dev
- gobject-introspection-dev"
+makedepends="
+ enchant2-dev
+ glib-dev
+ gobject-introspection-dev
+ gtk+3.0-dev
+ iso-codes-dev
+ vala
+ "
checkdepends="xvfb-run hunspell-en ibus"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-dbg"
+subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/gspell/${pkgver%.*}/gspell-$pkgver.tar.xz"
-case "$CARCH" in
- s390x)
- options="!check" # Requires ibus which is s390x-only
- ;;
-esac
-
build() {
./configure \
--build=$CBUILD \
@@ -33,11 +33,13 @@ build() {
}
check() {
- xvfb-run make check
+ xvfb-run -a make check
}
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="72f1fb384e02bb73397b457c3e8a7b98393c9fab5c0dad07f84d1db3f6b75c093663cc83c13fefe868424c503abc2fb89c8b045d0495dd43ddcedad025f23bca gspell-1.9.1.tar.xz"
+sha512sums="
+c13df805f6128cfd19c41e4936fbb49516f80e09d27e79380d5638cbd1a8a3bfc6aae5ef8a4faa748495fe529bde92805bbd5530610b113c58daa36f273a5af8 gspell-1.12.2.tar.xz
+"